您的位置:首页 > 其它

POJ 题目1753 Flip Game(DFS)

2015-04-26 22:49 429 查看
Flip Game

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 33029Accepted: 14435
Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces,
thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules:

Choose any one of the 16 pieces.

Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).


Consider the following position as an example:

bwbw

wwww

bbwb

bwwb

Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become:

bwbw

bwww

wwwb

wwwb

The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal.

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.
Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible"
(without quotes).
Sample Input
bwwb
bbwb
bwwb
bwww

Sample Output
4

Source
Northeastern Europe 2000
ac代码
#include<stdio.h>
#include<string.h>
int map[10][10],step,flag=0;
int dx[5]={0,0,0,-1,1};
int dy[5]={1,-1,0,0,0};
int jud()
{
int i,j;
for(i=1;i<=4;i++)
for(j=1;j<=4;j++)
{
if(map[i][j]!=map[1][1])
return 0;
}
return 1;
}
void fun(int x,int y)
{
int i,j;
for(i=0;i<5;i++)
{
int fx=x+dx[i];
int fy=y+dy[i];
map[fx][fy]=!map[fx][fy];
}
}
void dfs(int x,int y,int cnt)
{
if(cnt==step)
{
flag=jud();
return;
}
if(flag)
return;
if(x==5)
return;
fun(x,y);
if(y<4)
dfs(x,y+1,cnt+1);
else
dfs(x+1,1,cnt+1);
fun(x,y);
if(y<4)
dfs(x,y+1,cnt);
else
dfs(x+1,1,cnt);
}
int main()
{
int i,j;
char c;
for(i=1;i<=4;i++)
{
for(j=1;j<=4;j++)
{
scanf("%c",&c);
if(c=='b')
map[i][j]=1;
}
getchar();
}
for(step=0;step<=16;step++)
{
dfs(1,1,0);
if(flag)
break;
}
if(flag)
printf("%d\n",step);
else
printf("Impossible\n");
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: