您的位置:首页 > 其它

ZOJ 3870 Team Formation(异或)

2015-04-26 20:46 405 查看
Team Formation

Time Limit: 3 Seconds Memory Limit: 131072 KB

For an upcoming programming contest, Edward, the headmaster of Marjar University, is forming a two-man team from N students of his university.
Edward knows the skill level of each student. He has found that if two students with skill level A and B form a team, the skill level of the team will be A ⊕ B,
where ⊕ means bitwise exclusive or. A team will play well if and only if the skill level of the team is greater than the skill level of each team member (i.e. A ⊕ B > max{A, B}).
Edward wants to form a team that will play well in the contest. Please tell him the possible number of such teams. Two teams are considered different if there is at least one different
team member.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:
The first line contains an integer N (2 <= N <= 100000), which indicates the number of student. The next line contains N positive integers separated by
spaces. The ith integer denotes the skill level of ith student. Every integer will not exceed 109.

Output

For each case, print the answer in one line.

Sample Input

2
3
1 2 3
5
1 2 3 4 5

Sample Output

1
6

题意:给你n个数,求n个数里满足A ⊕ B > max{A, B}的对数。

题解:首先,A ⊕ B > max{A, B},假设A>B,则B的二进制最高位对应的A的为一定要为0,才能满足⊕ B > max{A, B}
        比如:      1001          1001
                           100           1000
       异或后       1101          0001
这样我们只需要记录二进制不同位数的个数,然后枚举每一位数的二进制数位,是0的话就加上这个位数的个数。

#include<cstdio>
#include<algorithm>
#include<cstring>
#include<iostream>
#include<cmath>
#define N 1001010
#define ll long long

using namespace std;

int n;
int a
;
int num
;
int p[33];
int b[66];
int l;

void init() {
    p[0]=1;
    for(int i=1; i<=30; i++)
        p[i]=p[i-1]*2;
}

void change(int x) {
    l=0;
    while(x) {
        b[l++]=x%2;
        x/=2;
    }
}
int main() {
    int t;
    cin>>t;
    init();
    while(t--) {
        cin>>n;
        memset(num,0,sizeof num);
        for(int i=0; i<n; i++) {
            scanf("%d",&a[i]);
            for(int j=30; j>=0; j--) {///位数
                if(a[i]>=p[j]) {
                    num[j]++;
                    break;
                }
            }
        }
        ll ans=0;
        for(int i=0; i<n; i++) {
            change(a[i]);
            for(int j=0; j<l; j++) {
                if(b[j]==0) {
                    ans+=num[j];
                }
            }
        }
        printf("%lld\n",ans);
    }
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: