您的位置:首页 > 其它

ZOJ 3870 Team Formation(数学)

2015-04-25 22:50 465 查看
Team Formation

Time Limit: 3 Seconds
Memory Limit: 131072 KB

For an upcoming programming contest, Edward, the headmaster of Marjar University, is forming a two-man team from
N students of his university.

Edward knows the skill level of each student. He has found that if two students with skill level
A and B form a team, the skill level of the team will be
A ⊕ B, where ⊕ means bitwise exclusive or. A team will play well if and only if the skill level of the team is greater than the skill level of each team member (i.e.
A ⊕ B > max{A, B}).

Edward wants to form a team that will play well in the contest. Please tell him the possible number of such teams. Two teams are considered different if there is at least one different team member.

Input

There are multiple test cases. The first line of input contains an integer
T indicating the number of test cases. For each test case:

The first line contains an integer N (2 <= N <= 100000), which indicates the number of student. The next line contains
N positive integers separated by spaces. The ith integer denotes the skill level of
ith student. Every integer will not exceed 109.

Output

For each case, print the answer in one line.

Sample Input

2
3
1 2 3
5
1 2 3 4 5

Sample Output

1
6


题意:求一个序列 a亦或b >max(a,b)的组合情况,没有顺序十分

思路:先排序,然后对与一个二进制数 他可以亦或大于他的数肯定是他的二进制中0的位置对方是1,并且这一位是对方的最高位

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>
#include<set>
#include<map>

#define L(x) (x<<1)
#define R(x) (x<<1|1)
#define MID(x,y) ((x+y)>>1)

#define eps 1e-8

#define fre(i,a,b) for(i = a; i <b; i++)
#define free(i,b,a) for(i = b; i >= a;i--)
#define mem(t, v) memset ((t) , v, sizeof(t))
#define ssf(n) scanf("%s", n)
#define sf(n) scanf("%d", &n)
#define sff(a,b) scanf("%d %d", &a, &b)
#define sfff(a,b,c) scanf("%d %d %d", &a, &b, &c)
#define pf printf
#define bug pf("Hi\n")

using namespace std;

#define INF 0x3f3f3f3f
#define N 100005
int vis
,a
;
int n,ans;

inline void call(int x)
{
int i=0;
while(x)
{
i++;
x>>=1;
}
vis[i-1]++;
}

inline void solve(int x)
{
int i;
fre(i,0,31)
if(!(x&(1<<i)))
ans+=vis[i];
}

int main()
{
int i,j,t;
sf(t);
while(t--)
{
sf(n);
fre(i,0,n)
sf(a[i]);

mem(vis,0);
sort(a,a+n);
call(a[0]);
ans=0;
fre(i,1,n)
{
solve(a[i]);
call(a[i]);
}
pf("%d\n",ans);

}
return 0;
}

/*

2 3 1 2 3 5 1 2 3 4 5
*/

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: