您的位置:首页 > 其它

杭电 HDU ACM 1171 Big Event in HDU

2015-04-25 20:37 281 查看

Big Event in HDU

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 26957 Accepted Submission(s): 9504



Problem Description
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.

The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is
N (0<N<1000) kinds of facilities (different value, different kinds).



Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding
number of the facilities) each. You can assume that all V are different.

A test case starting with a negative integer terminates input and this test case is not to be processed.



Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that
A is not less than B.



Sample Input
2
10 1
20 1
3
10 1 
20 2
30 1
-1




Sample Output
20 10
40 40




Author
lcy

母函数 做的越来越难了 但是 有意思的是万变不离其宗,要注意,用来保存最终系数的那个数组,我们仅仅 研究的是总价值的二分之一,所以只要保存指数小于等于sum/2的
系数情况,如果系数不为0,那么对于那些机器 存在某种组合形成这种价值。那么只要找出靠近中指的&&能够形成的这种组合指数值(价值)。
#include<iostream>
using namespace std;
struct fac
{
   int v,m;
}per[51];
int main()
{
    int i,T,j,k,cnt[100001],dic[100001];
    while(cin>>T&&T>=0)
    {
        int sum=0;
        for(int p=0;p<T;p++)
        {cin>>per[p].v>>per[p].m;sum+=per[p].v*per[p].m;}
        int M=sum/2;
            for(int p=0;p<=M;p++)
        {cnt[p]=0;dic[p]=0;}
        for(int q=0;q<=per[0].m*per[0].v;q+=per[0].v)
        {
            cnt[q]=1;
        }
        for(i=2;i<=T;i++)
        {
            for(j=0;j<=M;j++)
                for(k=0;(k+j<=M)&&(k<=per[i-1].v*per[i-1].m);k+=per[i-1].v)
            {
                dic[j+k]+=cnt[j];
            }
            for(int h=0;h<=M;h++)
            {
                cnt[h]=dic[h];
                dic[h]=0;
            }

        }
        int x=M;

        while(!cnt[M])
        {
            M--;
        }
        cout<<sum-M<<" "<<M<<endl;
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: