您的位置:首页 > 其它

NYOJ 58 最小步数【bfs】

2015-04-25 10:23 253 查看


最少步数

时间限制:3000 ms | 内存限制:65535 KB
难度:4

描述

这有一个迷宫,有0~8行和0~8列:

1,1,1,1,1,1,1,1,1

1,0,0,1,0,0,1,0,1

1,0,0,1,1,0,0,0,1

1,0,1,0,1,1,0,1,1

1,0,0,0,0,1,0,0,1

1,1,0,1,0,1,0,0,1

1,1,0,1,0,1,0,0,1

1,1,0,1,0,0,0,0,1

1,1,1,1,1,1,1,1,1

0表示道路,1表示墙。

现在输入一个道路的坐标作为起点,再如输入一个道路的坐标作为终点,问最少走几步才能从起点到达终点?

(注:一步是指从一坐标点走到其上下左右相邻坐标点,如:从(3,1)到(4,1)。)

输入第一行输入一个整数n(0<n<=100),表示有n组测试数据;

随后n行,每行有四个整数a,b,c,d(0<=a,b,c,d<=8)分别表示起点的行、列,终点的行、列。
输出输出最少走几步。
样例输入
2
3 1  5 7
3 1  6 7


样例输出
12
11


来源[苗栋栋]原创
上传者
苗栋栋
AC代码
#include<stdio.h>
#include <iostream>
#include<queue>
using namespace std;
int dudu[4][2]= {1,0,-1,0,0,1,0,-1};
struct point
{
    int x,y,step;
};
int bfs(point s,point e,int map[9][9])
{
    queue<point>tp ;
    s.step=0;
    map[s.x][s.y]=1;
    tp.push(s);
    point t;
    while(!tp.empty())
    {s=tp.front();
    tp.pop();
        if(s.x==e.x&&s.y==e.y){
//       
            return s.step;
        }

        else
        {

        for(int i=0;i<4;i++)
        {
            t.x=s.x+dudu[i][0];//从原来的基础上挪一位
            t.y=s.y+dudu[i][1];//从原来的基础上挪一位
            if(map[t.x][t.y]==0)
            {
                t.step=s.step+1;//从原来的基础上只加一步
                map[t.x][t.y]=1;
                tp.push(t);
            }
        }
    }
    }
    return -1;//搜不到的情况下要有一个返回值
}
int main()
{
    int n;
    scanf("%d",&n);
    while(n--)
    {
        point s ,e;
        int map[9][9]= {1,1,1,1,1,1,1,1,1,
                        1,0,0,1,0,0,1,0,1,
                        1,0,0,1,1,0,0,0,1,
                        1,0,1,0,1,1,0,1,1,
                        1,0,0,0,0,1,0,0,1,
                        1,1,0,1,0,1,0,0,1,
                        1,1,0,1,0,1,0,0,1,
                        1,1,0,1,0,0,0,0,1,
                        1,1,1,1,1,1,1,1,1,
                       };
        scanf("%d%d%d%d",&s.x,&s.y,&e.x,&e.y);

        printf("%d\n",bfs(s,e,map));
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: