您的位置:首页 > 其它

HDU 1007 Quoit Design

2015-04-24 10:30 351 查看
Problem Description
Have you ever played quoit in a playground? Quoit is agame in which flat rings are pitched at some toys, with all the toys encircledawarded.

In the field of Cyberground, the position of each toy is fixed, and the ring iscarefully designed so it can only encircle one toy at a time. On the otherhand, to make the game look more attractive, the ring is designed to have thelargest radius. Given a configuration
of the field, you are supposed to findthe radius of such a ring.

Assume that all the toys are points on a plane. A point is encircled by thering if the distance between the point and the center of the ring is strictlyless than the radius of the ring. If two toys are placed at the same point, theradius of the ring is considered
to be 0.

Input
The input consists of several test cases. For each case,the first line contains an integer N (2 <= N <= 100,000), the totalnumber of toys in the field. Then N lines follow, each contains a pair of (x,y) which are the coordinates of a toy. The
input is terminated by N = 0.
Output
For each test case, print in one line the radius of thering required by the Cyberground manager, accurate up to 2 decimal places.
Sample Input
2
0 0
1 1
2
1 1
1 1
3
-1.5 0
0 0
0 1.5
0
Sample Output
0.71
0.00
0.75
平面最近点对问题
#include <stdio.h>

#include <math.h>

#include <string.h>

#include <stdlib.h>

const int N=100005;

const double MAX=10e100,eps=0.00001;

struct point

{

double x,y;

int index;

};

point a
,b
,c
;

double dis(point p,point q)

{

double x1=p.x-q.x,y1=p.y-q.y;

return sqrt(x1*x1+y1*y1);

}

double minx(double p,double q)

{

return q<p?q:p;

}

int merge(point p[],point q[],int s,intm,int t)

{

int i,j,k;

for(i=s,j=m+1,k=s;i<=m&&j<=t;)

{

if(q[i].y>q[j].y) p[k++]=q[j],j++;

else

p[k++]=q[i],i++;

}

while(i<=m) p[k++]=q[i++];

while(j<=t) p[k++]=q[j++];

memcpy(q+s,p+s,(t-s+1)*sizeof(p[0]));

return 0;

}

double closest(point a[],point b[],pointc[],int p,int q)

{

if(q-p==1)return dis(a[p],a[q]);

if(q-p==2)

{

double x1=dis(a[p],a[q]);

double x2=dis(a[p+1],a[q]);

double x3=dis(a[p],a[p+1]);

if(x1<x2&&x1<x3) return x1;

else if(x2<x3) return x2;

else return x3;

}

int i,j,k,m=(p+q)/2;

double d1,d2;

for(i=p,j=p,k=m+1;i<=q;i++)

if(b[i].index<=m) c[j++]=b[i];

else

c[k++]=b[i];

d1=closest(a,c,b,p,m);

d2=closest(a,c,b,m+1,q);

double dm=minx(d1,d2);

merge(b,c,p,m,q);

for(i=p,k=p;i<=q;i++)

if(fabs(b[i].x-b[m].x)<dm)

c[k++]=b[i];

for(i=p;i<k;i++)

for(j=i+1;j<k&&c[j].y-c[i].y<dm;j++)

{

double temp=dis(c[i],c[j]);

if(temp<dm)

dm=temp;

}

return dm;

}

int cmp_x(const void*p,const void *q)

{

double temp=((point*)p)->x-((point*)q)->x;

if(temp>0)

return 1;

else if(fabs(temp)<eps) return 0;

else return -1;

}

int cmp_y(const void*p,const void *q)

{

double temp=((point*)p)->y-((point*)q)->y;

if(temp>0)

return 1;

else if(fabs(temp)<eps) return 0;

else return -1;

}

int main()

{

int n,i;

double d;

while(scanf("%d",&n)&&n!=0)

{

for(i=0;i<n;i++)

scanf("%lf%lf",&(a[i].x),&(a[i].y));

qsort(a,n,sizeof(a[0]),cmp_x);

for(i=0;i<n;i++)

a[i].index=i;

memcpy(b,a,n*sizeof(a[0]));

qsort(b,n,sizeof(b[0]),cmp_y);

d=closest(a,b,c,0,n-1);

printf("%.2lf\n",d/2);

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: