您的位置:首页 > 其它

poj 1236 强连通分量+缩点

2015-04-23 22:52 267 查看
Network of Schools

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 12273 Accepted: 4887
Description
A number of schools are connected to a computer network. Agreements have been developed among those schools: each school maintains a list of schools to which it distributes software (the “receiving schools”). Note that if B is
in the distribution list of school A, then A does not necessarily appear in the list of school B

You are to write a program that computes the minimal number of schools that must receive a copy of the new software in order for the software to reach all schools in the network according to the agreement (Subtask A). As a further task, we want to ensure that
by sending the copy of new software to an arbitrary school, this software will reach all schools in the network. To achieve this goal we may have to extend the lists of receivers by new members. Compute the minimal number of extensions that have to be made
so that whatever school we send the new software to, it will reach all other schools (Subtask B). One extension means introducing one new member into the list of receivers of one school.

Input
The first line contains an integer N: the number of schools in the network (2 <= N <= 100). The schools are identified by the first N positive integers. Each of the next N lines describes a list of receivers. The line i+1 contains
the identifiers of the receivers of school i. Each list ends with a 0. An empty list contains a 0 alone in the line.
Output
Your program should write two lines to the standard output. The first line should contain one positive integer: the solution of subtask A. The second line should contain the solution of subtask B.

Sample Input
5
2 4 3 0
4 5 0
0
0
1 0

Sample Output
1
2

Source
IOI 1996

5
2 4 3 0
4 5 0
0
0
1 0
#include <iostream>
#include <cstring>
#include <string>
#include <cstdio>
#include <algorithm>
#include <vector>
#include <set>
#include <map>
#include <stack>
#include <queue>
using namespace std;

#define maxn 101
#define maxm 20005
int n;
int to[maxm],next[maxm],first[maxn],tot;
int rto[maxm], rnext[maxm],rfirst[maxn], rtot;
int vs[maxn],cnt=0;
bool used[maxn];
int cmp[maxn];
int ind[maxn];
int outd[maxn];

void init()
{
memset(first, -1, sizeof(first));
memset(rfirst, -1, sizeof(rfirst));
tot=rtot=0;
cnt=0;
}
void add(int u, int v)
{
to[tot]=v; next[tot]=first[u]; first[u]=tot++;
rto[rtot]=u; rnext[rtot]=rfirst[v]; rfirst[v]=rtot++;
}

void dfs(int u)
{
int v;
used[u]=1;
for(int i=first[u]; i!=-1; i=next[i]){
v=to[i];
if(!used[v]) dfs(v);
}
vs[cnt++]=u;
}

void rdfs(int u, int k)
{
int v;
cmp[u]=k;
used[u]=1;
for(int i=rfirst[u]; i!=-1; i=rnext[i]){
v=rto[i];
if(!used[v]) rdfs(v, k);
}
}

int scc(int n)
{
cnt=0;
memset(used,0, sizeof(used));
for(int i=1; i<=n; i++)
if(!used[i]){
dfs(i);
}

memset(used, 0, sizeof(used));
cnt=0;
for(int i=n-1; i>=0; i--)
if(!used[vs[i]])
rdfs(vs[i], cnt++);
return cnt;

}

int main()
{
while(scanf("%d", &n)==1){
init();
int u,v;
memset(ind, 0, sizeof(ind));
memset(outd, 0, sizeof(outd));
for(int i=0; i<n; i++){
u=i+1;
while(scanf("%d", &v)==1 && v){
add(u,v);
}
}

int num=scc(n);
for(int i=1; i<=n; i++){
u=i;
for(int j=first[u]; j!=-1; j=next[j]){
v=to[j];
if(cmp[u]!=cmp[v])
ind[cmp[v]]++,outd[cmp[u]]++;
}
}

int ansa=0, ansb=0;
for(int i=0; i<num; i++){
if(!ind[i]) ansa++;
if(!outd[i]) ansb++;
}

ansb=max(ansa, ansb);
if(num==1) ansb=0;
printf("%d\n%d\n", ansa,ansb);
}
return 0;
}


Sample Output
1
2

Source
IOI 1996
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  scc 缩点