您的位置:首页 > 其它

HDU--1686(kmp,模板题)

2015-04-23 20:46 369 查看


Oulipo

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 6107 Accepted Submission(s): 2454



Problem Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination,
l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that
counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All
the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.



Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).

One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.



Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.



Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
***ERDXIVYERDIAN




Sample Output

1
3
0还是模板题
代码:
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<string>
#include<cmath>
#include<queue>
#include<map>
#include<set>
#define INF 0x3f3f3f3f
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
const int maxd=1000000+5;
const int maxn=10000+5;
typedef long long ll;
typedef pair<int,int> pii;
//---------------------------
int n,m,ans;
string a,b;
vector<int> pos;

void find_substring(string a,string b)
{
    vector<int> next(m+1,0);
    for(int i=1; i<m; ++i)
    {
        int j=i;
        while(j>0)
        {
            j=next[j];
            if(b[j]==b[i])
            {
                next[i+1]=j+1;
                break;
            }
        }
    }
    for(int i=0,j=0; i<n; ++i)
    {
        if(j<m && a[i]==b[j])
            ++j;
        else
        {
            while(j>0)
            {
                j=next[j];
                if(a[i]==b[j])
                {
                    ++j;
                    break;
                }
            }
        }
        if(j==m) ans++;
    }
}

int main()
{
    freopen("in.txt", "r", stdin);
    int kase;
    cin>>kase;
    while(kase--)
    {
        ans=0;
        cin>>b>>a;
        n=a.length(),m=b.length();
        find_substring(a,b);
        printf("%d\n",ans);
    }

    return 0;
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: