您的位置:首页 > 其它

ACM--steps--dyx--5.1.4--find the most comfortable road

2015-04-23 12:37 453 查看

find the most comfortable road

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 193 Accepted Submission(s): 94
[align=left]Problem Description[/align]
XX星有许多城市,城市之间通过一种奇怪的高速公路SARS(Super Air Roam Structure---超级空中漫游结构)进行交流,每条SARS都对行驶在上面的Flycar限制了固定的Speed,同时XX星人对 Flycar的“舒适度”有特殊要求,即乘坐过程中最高速度与最低速度的差越小乘坐越舒服 ,(理解为SARS的限速要求,flycar必须瞬间提速/降速,痛苦呀 ),

但XX星人对时间却没那么多要求。要你找出一条城市间的最舒适的路径。(SARS是双向的)。

[align=left]Input[/align]
输入包括多个测试实例,每个实例包括:

第一行有2个正整数n (1<n<=200)和m (m<=1000),表示有N个城市和M条SARS。

接下来的行是三个正整数StartCity,EndCity,speed,表示从表面上看StartCity到EndCity,限速为speedSARS。speed<=1000000

然后是一个正整数Q(Q<11),表示寻路的个数。

接下来Q行每行有2个正整数Start,End, 表示寻路的起终点。

[align=left]Output[/align]
每个寻路要求打印一行,仅输出一个非负整数表示最佳路线的舒适度最高速与最低速的差。如果起点和终点不能到达,那么输出-1。

[align=left]Sample Input[/align]

4 4
1 2 2
2 3 4
1 4 1
3 4 2
2
1 3
1 2


[align=left]Sample Output[/align]

1
0


[align=left]Author[/align]
ailyanlu

[align=left]Source[/align]
HDU 2007-Spring Programming Contest - Warm Up (1)

[align=left]Recommend[/align]
8600

#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
int n,m;//表示所在城市数和共有m条道路;
const int Max=1009;
int dyx[209];//表示每一个节点所在的上一个节点;
const int INF=9999999;
int min(int a,int b)
{
if(a>b)
return b;
else
return a;
}
class Node
{
public:
int s,e,spe;//分别表示起点,终点,速度;
}wyx[Max];
//查询根节点;
bool cmp(Node a,Node b)
{
//将速度以升序进行排列;
return a.spe<b.spe;
}
int find(int x)
{
int r=x;
while(dyx[r]!=r)
{
r=dyx[r];
}
return r;
}
//初始化;
void init()
{
for(int i=1;i<=n;i++)
{
dyx[i]=i;
}
}
//合并;
void mix(int a,int b)
{
int RootA=find(a);
int RootB=find(b);
if(RootA!=RootB)
{
dyx[RootA]=RootB;
}
}
int main()
{
while(cin>>n>>m)
{
for(int i=0;i<m;i++)
{
cin>>wyx[i].s>>wyx[i].e>>wyx[i].spe;
}
sort(wyx,wyx+m,cmp);
int T;
cin>>T;
while(T--)
{
int ans=INF;
int St,Ed;
cin>>St>>Ed;
//进行枚举所有的值;
for(int i=0;i<m;i++)
{
//进行每一次的搜索前要先进行初始化;
init();
//遍历所有的情况,从当前的i值为起始点;
for(int j=i;j<m;j++)
{
//将当前起始点与终点合并;
mix(wyx[j].s,wyx[j].e);
//当起点和终点连通起来的时候;'
if(find(St)==find(Ed))
{
//sort排序保证当前的值为最优解;
ans=min(ans,wyx[j].spe-wyx[i].spe);
break;
}
}
}
if(ans==INF)
cout<<-1<<endl;
else
cout<<ans<<endl;
}
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: