您的位置:首页 > 产品设计 > UI/UE

hdu 2818 Building Block(带权并查集)

2015-04-22 21:57 441 查看

Building Block

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3629 Accepted Submission(s): 1093



Problem Description
John are playing with blocks. There are N blocks (1 <= N <= 30000) numbered 1...N。Initially, there are N piles, and each pile contains one block. Then John do some operations P times (1 <= P <= 1000000). There are two kinds of operation:

M X Y : Put the whole pile containing block X up to the pile containing Y. If X and Y are in the same pile, just ignore this command.

C X : Count the number of blocks under block X

You are request to find out the output for each C operation.



Input
The first line contains integer P. Then P lines follow, each of which contain an operation describe above.


Output
Output the count for each C operations in one line.


Sample Input
6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4




Sample Output
1
0
2




Source
2009 Multi-University Training Contest 1 - Host by TJU

题目分析:

这道题是集合合并的问题,所以可以利用并查集解决,只需记录当前堆的总数,和每个块下面的总数,记录下来,每次合并时,就是新的根持有当前新的堆的大小,当前在上端块的根的下面的就是下面堆的块的总数,然后因为上面的在下次查找路径时,会加上父亲底部的总数,所以在每次find能维护并查集的性质,重点是利用sum数组对并查集两个堆进行合并的处理

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#define MAX 30007

using namespace std;

int n,a,b;
char s[10];

int fa[MAX];
int sum[MAX];
int under[MAX];

void init ( )
{
    for ( int i = 0 ; i < MAX ; i++ )
        fa[i] = i,sum[i] = 1;
    memset ( under , 0 , sizeof ( under ) );
}

int find ( int x )
{
    if ( fa[x] == x ) return x;
    else
    {
        int temp = find(fa[x]);
        under[x] += under[fa[x]];
        return fa[x] = temp;
    }
}

void _union ( int x , int y )
{
    x = find ( x );
    y = find ( y );
    if ( x == y ) return;
    fa[x] = y;
    under[x] = sum[y];
    sum[y] += sum[x];
}

int main ( )
{
    while ( ~scanf ( "%d" , &n ) )
    {
        init ( );
        while ( n-- )
        {
            scanf ( "%s" , s );
            if ( s[0] == 'M' )
            {
                scanf ( "%d%d" , &a , &b );
                _union ( a , b );
            }
            else
            {
                scanf ( "%d" , &a );
                find ( a );
                printf ( "%d\n" , under[a] );
            }
        }
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: