您的位置:首页 > 其它

Hdoj 1075 What Are You Talking About 【MAP】

2015-04-22 19:23 330 查看
What Are You Talking About

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 102400/204800 K (Java/Others)

Total Submission(s): 15322 Accepted Submission(s): 4922

Problem Description

Ignatius is so lucky that he met a Martian yesterday. But he didn’t know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?

Input

The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string “START”, this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian’s language. A line with a single string “END” indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string “START”, this string should be ignored, then an article written in Martian’s language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can’t find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(’ ‘), tab(‘\t’), enter(‘\n’) and all the punctuation should not be translated. A line with a single string “END” indicates the end of the book part, and that’s also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.

Output

In this problem, you have to output the translation of the history book.

Sample Input

START

from fiwo

hello difh

mars riwosf

earth fnnvk

like fiiwj

END

START

difh, i’m fiwo riwosf.

i fiiwj fnnvk!

END

Sample Output

hello, i’m from mars.

i like earth!

Hint

Huge input, scanf is recommended.

题意:给出一个字典,再给出一行字符串,如果字符串里面的单词在字典里,那么就输出对应的单词,反之直接输出。

用map映射一下就好了。

代码:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <map>
using namespace std;
const int M = 3e5;

char s[M];
map<string, string> m;

int main(){
    /*char a[15], b[15];
    scanf("%s", a);*/
   // ios::sync_with_stdio(false);
    string a, b;
    cin >> a;
    while(cin>>a, a != "END"){
            cin>>b;
        //scanf("%s", b);
        m[b] = a;
    }
    map<string, string>::iterator it = m.begin();
    /*for(; it != m.end(); ++ it){
            cout << it->first<<" "<<it->second<<endl;
        //printf("%s %s..\n", it->first, it->second);
    }*/
    cin>>a;
    //scanf("%s", a);
    getchar();
    while(gets(s), strcmp(s, "END")){
        int len = strlen(s);
        string temp;
        int i = 0, j = 0;
        while(i<len){
            if(s[i] >= 'a'&&s[i] <= 'z'){
                temp += s[i]; ++i;
            }
            else{
                //temp[j] = '\0';
                map<string, string>::iterator it = m.find(temp);
                if(it != m.end()){
                   cout << it->second;
                }
                else cout << temp;
                while(i < len&&(s[i]<'a'||s[i]>'z')){
                    printf("%c", s[i]); ++i;
                }
                //j = 0;
                temp.clear();
            }
        }
        cout << endl;
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: