您的位置:首页 > 其它

hdu 2971 Tower(矩阵快速幂)

2015-04-21 17:47 302 查看

Tower

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2521 Accepted Submission(s): 567



Problem Description
Alan loves to construct the towers of building bricks. His towers consist of many cuboids with square base. All cuboids have the same height h = 1. Alan puts the consecutive cuboids one over another:



Recently in math class, the concept of volume was introduced to Alan. Consequently, he wants to compute the volume of his tower now. The lengths of cuboids bases (from top to bottom) are constructed by Alan in the following way:

1. Length a1 of the first square is one.

2. Next, Alan fixes the length a2 of the second square.

3. Next, Alan calculates the length an (n > 2) by 2*a2*(an-1)-(an-2). Do not ask why he chose such

a formula; let us just say that he is a really peculiar young fellow. For example, if Alan fixes a2 = 2, then a3 = 8 -a1 = 7; see Figure 1. If Alan fixes a2 = 1, then an = 1 holds for all n belong to N; see Figure 2.

Now Alan wonders if he can calculate the volume of tower of N consecutive building bricks. Help Alan and write the program that computes this volume. Since it can be quite large, it is enough to compute the answer modulo given natural number m.


Input
The input contains several test cases. The first line contains the number t (t <= 10^5) denoting the number of test cases. Then t test cases follow. Each of them is given in a separate line containing three integers a2,N,m (1 <= a2,m
<= 10^9, 2 <= N <= 10^9) separated by a single space, where a2 denotes the fixed length of second square in step 2, while N denotes the number of bricks constructed by Alan.


Output
For each test case (a2,N,m) compute the volume of tower of N consecutive bricks constructed by Alan according to steps (1-3) and output its remainder modulo m.


Sample Input
3
2 3 100
1 4 1000
3 3 1000000000




Sample Output
54
4
299
Hint





Source
Central European Programming Contest 2008



题目分析:

这道题又教我怎么做人了。。。

模没取够要溢出,取多了会超时,必要时要手动模拟取模,这道题要求的是sum(Ai^2)

那么如何递推呢,设Ai = XAi-1 + YAi-2

那么Ai^2=X^2*Ai-1^2+2*X*Y*Ai-1*Ai-2+Y^2*A-2^2

而Ai-1*Ai-2 = (XAi-2+YAi-3)*Ai-2 = X*Ai-1^2+Y*Ai-2*Ai-3

那么就可以通过递推得到

#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>
#define MAX 4

using namespace std;

typedef long long LL;

int t;
LL a2,n,m;

struct Matrix
{
    LL a[MAX][MAX];
    Matrix ( )
    {
        memset ( a, 0 , sizeof ( a ) );
    }
};

Matrix multi ( Matrix& m1 , Matrix& m2 )
{
    Matrix ret;
    for ( int i = 0 ; i < MAX ; i++ )
        for ( int j = 0 ; j < MAX ; j++ )
            if ( m1.a[i][j] )
                for ( int k = 0 ; k < MAX ; k++ )
                {
                    LL temp = m1.a[i][j]*m2.a[j][k]%m;
                    if ( temp < 0 ) temp += m;
                    ret.a[i][k] += temp;
                    if ( ret.a[i][k] >=  m ) ret.a[i][k] -= m;
                    if ( ret.a[i][k] < 0 ) ret.a[i][k] += m;
                }
                //ret.a[i][k] = ( ret.a[i][k] + m1.a[i][j]*m2.a[j][k]%m+m )%m;
    return ret;
}

Matrix quick ( Matrix& m , int n )
{
    Matrix ret;
    for ( int i = 0 ; i < MAX ; i++ )
        ret.a[i][i] = 1;
    while ( n )
    {
        if ( n&1 ) ret = multi ( ret , m );
        m = multi ( m , m );
        n >>= 1;
    }
    return ret;
}

void print ( Matrix m )
{
    for ( int i = 1 ; i < MAX ; i ++ )
    {
        for ( int j = 1 ; j < MAX ; j++ )
            printf ( "%lld " , m.a[i][j] );
        puts ("");
    }
}

int main ( )
{
    scanf ( "%d" , &t );
    while ( t-- )
    {
        scanf ( "%lld%lld%lld" , &a2 , &n , &m );
        Matrix ans;
        ans.a[0][0] = 1;
        ans.a[0][1] = a2*a2%m;
        ans.a[0][2] = 1;
        ans.a[0][3] = a2%m;
       // print ( ans );
       // puts ("");
        Matrix vary;
        vary.a[0][0] = 1;
        vary.a[1][0] = 1;
        vary.a[1][1] = 4*a2%m*a2%m;
        vary.a[2][1] = 1;
        vary.a[3][1] = (-4*a2%m+m)%m;
        vary.a[1][2] = 1;
        vary.a[1][3] = 2*a2%m;
        vary.a[3][3] = -1;
       // print ( vary );
        vary = quick ( vary , n-1 );
        ans = multi ( ans , vary );
        printf ( "%lld\n" , (ans.a[0][0]+m)%m );
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: