您的位置:首页 > 其它

hdu 1907 John(anti-nim)

2015-04-20 15:04 435 查看

John

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 65535/32768 K (Java/Others)

Total Submission(s): 3308 Accepted Submission(s): 1866



Problem Description
Little John is playing very funny game with his younger brother. There is one big box filled with M&Ms of different colors. At first John has to eat several M&Ms of the same color. Then his opponent has to make a turn. And so on.
Please note that each player has to eat at least one M&M during his turn. If John (or his brother) will eat the last M&M from the box he will be considered as a looser and he will have to buy a new candy box.

Both of players are using optimal game strategy. John starts first always. You will be given information about M&Ms and your task is to determine a winner of such a beautiful game.



Input
The first line of input will contain a single integer T – the number of test cases. Next T pairs of lines will describe tests in a following format. The first line of each test will contain an integer N – the amount of different M&M
colors in a box. Next line will contain N integers Ai, separated by spaces – amount of M&Ms of i-th color.

Constraints:

1 <= T <= 474,

1 <= N <= 47,

1 <= Ai <= 4747



Output
Output T lines each of them containing information about game winner. Print “John” if John will win the game or “Brother” in other case.



Sample Input
2
3
3 5 1
1
1




Sample Output
John
Brother




Source
Southeastern Europe 2007

题目分析:

反尼姆博弈,就是必胜态是S2,S1,T0,必败态是T2,S0

S代表堆的亦或和不为0,T代表堆的亦或和为0

只有一个石头的堆叫做孤单堆,有多个石头的堆叫做正常堆,那么当正常堆只有一个 时,因为高位一定之存在一个,所以只有S1而没有T1,那么根据实际情况的,T2能够转移到的只有S2,S1,因为无论T堆中取出任何数,剩下的堆都不能保证亦或和为0,只可能通过是否拿掉一整堆来判断是S2还是S1,如果是S1,一定能够通过取石子得到S0,而S0只能得到T0,对于S2,一定能够通过取数到达T2(nim游戏中可以理解到这一点),所以必胜态是S2,S1,T0,根据这个结论就可以得到最终结果

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>

using namespace std;

int t,n,a,ans,sum;

int main ( )
{
    scanf ( "%d" , &t );
    while ( t-- )
    {
        scanf ( "%d" , &n );
        sum = ans = 0;
        for ( int i = 0 ; i < n ; i++ )
        {
            scanf ( "%d" , &a );
            ans ^= a;
            if ( a > 1 ) sum++;
        }
        if ( ( ans == 0 && sum == 0 ) || ( ans != 0 && sum != 0 ) )
           printf ( "John\n" ); 
        else printf ( "Brother\n" );
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: