您的位置:首页 > 其它

BestCoder Round #38 1002——数学——Greatest Greatest Common Divisor

2015-04-19 20:42 337 查看
Problem Description

Pick two numbers ai,aj(i≠j) from a sequence to maximize the value of their greatest common divisor.

Input

Multiple test cases. In the first line there is an integer T, indicating the number of test cases. For each test cases, the first line contains an integer n, the size of the sequence. Next line contains n numbers, from a1 to an. 1≤T≤100,2≤n≤105,1≤ai≤105. The case for n≥104 is no more than 10.

Output

For each test case, output one line. The output format is Case #x: ans, x is the case number, starting from 1, ans is the maximum value of greatest common divisor.

Sample Input

2
4
1 2 3 4
3
3 6 9


Sample Output

Case #1: 2
Case #2: 3

大意:最大公约数得一种求法,以i为最大公约数,如果i*j存在的话说明这个数被i整除,只要看有多少个数符合这个条件那么i就是这个最大公约数

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAX = 100010;
int a[MAX];
int num[MAX];
int main()
{
int temp = 1;
int n,T;
scanf("%d",&T);
while(T--){
int max1 = 0;
memset(a,0,sizeof(a));
memset(num,0,sizeof(num));
scanf("%d",&n);
for(int i = 1; i <= n ; i++)
scanf("%d",&a[i]);
for(int i = 1; i <= n ; i++)
num[a[i]]++;
for(int i = 1; i <= 100000; i++){
int tot = 0;
for(int j = 1 ; i*j <= 100000;j++)
tot += num[i*j];
if(tot >= 2)
max1 = max(max1,i);
}
printf("Case #%d :%d\n",temp++,max1);
}
return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: