您的位置:首页 > 其它

hdu 1028 Ignatius and the Princess III(母函数)

2015-04-18 21:46 375 查看

Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 14796 Accepted Submission(s): 10421



Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:

N=a[1]+a[2]+a[3]+...+a[m];

a[i]>0,1<=m<=N;

My question is how many different equations you can find for a given N.

For example, assume N is 4, we can find:

4 = 4;

4 = 3 + 1;

4 = 2 + 2;

4 = 2 + 1 + 1;

4 = 1 + 1 + 1 + 1;

so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"



Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.



Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.



Sample Input
4
10
20




Sample Output
5
42
627




Author
Ignatius.L
题目分析:

母函数模板提

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#define MAX 157

using namespace std;

typedef long long LL;

LL a[MAX],b[MAX];
int n;

int main ( )
{
    memset ( a , 0 , sizeof ( a ) );
    for ( int i = 0 ; i <= 120 ; i++ )
        a[i] = 1;
    for ( int i = 2 ; i <= 120 ; i++ )
    {
        memset ( b , 0 , sizeof ( b ) );
        for ( int j = 0 ; j <= 120 ; j++ )
            for ( int k = 0 ; k*i <= 120 ; k++ )
                if ( k*i+j <= 120 ) b[k*i+j] += a[j];
        for ( int j = 0 ; j <= 120 ; j++ )
            a[j] = b[j];
    }
    while ( ~scanf ( "%d" , &n ) )
    {
        printf ( "%lld\n" , a
 );
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: