您的位置:首页 > 其它

HDU 2795-Billboard(线段树)

2015-04-17 18:50 260 查看


Billboard

Time Limit: 20000/8000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 13015 Accepted Submission(s): 5638



Problem Description

At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu,
and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.

Input

There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.

Output

For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard,
output "-1" for this announcement.

Sample Input

3 5 5
2
4
3
3
3


Sample Output

1
2
1
3
-1


题意:在大学门口,有一个高位h 宽为w的广告牌,现在广告牌是空的,有一些小的广告要张贴到广告牌上,已知这些小广告的高度都是1,宽为wi,张贴有一定规律,按照顺序来,并且往最高处贴,如果最高处贴不开就往下一行贴,输出每一张广告贴在的行,若果广告牌上贴不开,就输出-1

#include <stdio.h>
#include <math.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <sstream>
#include <algorithm>
#include <set>
#include <queue>
#include <stack>
#include <map>
using namespace std;
typedef long long LL;
const int inf=0x3f3f3f3f;
const double pi= acos(-1.0);
#define lson l,mid,rt<<1
#define rson mid+1,r,rt<<1|1
const int MAXN=200010;
int sum[MAXN<<2];
int h,w,n;
int num;
void PushUp(int rt)
{
sum[rt]=max(sum[rt<<1],sum[rt<<1|1]);
}

void Build(int l,int r,int rt)
{
sum[rt]=w;
if(l==r) {
return ;
}
int mid=(l+r)>>1;
Build(lson);
Build(rson);
}

void Query(int x,int l,int r,int rt)
{
if(l==r) {
num=l;
sum[rt]-=x;
return ;
}
int mid=(l+r)>>1;
if(x<=sum[rt<<1]) {
Query(x,lson);
PushUp(rt);
return ;
}
if(x<=sum[rt<<1|1]) {
Query(x,rson);
PushUp(rt);
return ;
}
}

int main()
{
int i,x;
while(~scanf("%d %d %d",&h,&w,&n)) {
h =min(h,n);
Build(1,n,1);
for(i=1; i<=n; i++) {
scanf("%d",&x);
if(x>sum[1])
printf("-1\n");
else {
Query(x,1,h,1);
printf("%d\n",num);
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: