您的位置:首页 > 其它

ZOJ - 3594 Sexagenary Cycle(公元没有0年)

2015-04-17 02:34 351 查看
Sexagenary Cycle

Time Limit: 2000MSMemory Limit: 65536KB64bit IO Format: %lld & %llu
Submit Status

Description

The Chinese sexagenary cycle, also known as the stems-and-branches, is a cycle of sixty terms used for recording days or years. Each term in the sexagenary cycle consists of two Chinese characters, the first representing a term from a cycle of ten known
as the heavenly stems and the second from a cycle of twelve known as the earthly branches. The first term (Jiazi) combines the first heavenly stem (Jia) with the first earthly branch (Zi). The second (Yichou) combines the second stem with the second branch.
This continues, generating a total of 60 different terms (the least common multiple of ten and twelve), after which the cycle repeats itself.

The ten heavenly stems are Jia, Yi, Bing, Ding, Wu, Ji, Geng, Xin, Ren and Gui. And the twelve earthly branches are Zi, Chou, Yin, Mao, Chen, Si, Wu, Wei, Shen, You, Xu and Hai. E.g. Xinhai Revolution occurred in 1911, the year of the Xinhai stem-branch
in the sexagenary cycle. And this year, namely 2012, is the year of Renchen. Given a year in western year, could you find out which year it is in cyclic year?

Actually, the cyclic year normally changes on the Chinese Lunar New Year, but you can ignore this in this problem.

Input

There are multiple test cases. The first line of input is an integer T ≈ 1000 indicating the number of test cases.

Each test case contains a positive integer or a negative integer. A positive integer n indicates n AD (Anno Domini), while a negative integer nindicates -n BC
(Before Christ). The absolute values of all integers are strictly less than 10000.

Output

For each test case, output a string -- the corresponding cyclic year.

Sample Input

2
1911
2012


Sample Output

Xinhai
Renchen

References

http://en.wikipedia.org/wiki/Sexagenary_cycle

#include<iostream>
#include<string>
#include<cstring>
using namespace std;
const string firs[20] = {  "Jia", "Yi", "Bing", "Ding", "Wu", "Ji", "Geng", "Xin", "Ren", "Gui" };
const string seco[20] = {  "zi", "chou", "yin", "mao", "chen", "si", "wu", "wei", "shen", "you", "xu", "hai" };

int main()
{
	int year;
	int f, s;
	int casen;
	cin >> casen;
	while (casen--)
	{
		cin >> year;
		if (year < 0) year++;
		if (year < 0)
			year = year + 12000;
		cout << firs[(year+6) % 10] << seco[(year+8) % 12] << endl;
	}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: