您的位置:首页 > 运维架构

poj 2115 C Looooops(解线性同余方程)

2015-04-16 11:14 399 查看
C Looooops

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 19017Accepted: 5003
Description
A Compiler Mystery: We are given a C-language style for loop of type

for (variable = A; variable != B; variable += C)

  statement;


I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming
that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2k) modulo 2k.

Input
The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop
and A, B, C (0 <= A, B, C < 2k) are the parameters of the loop.

The input is finished by a line containing four zeros.

Output
The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the
loop does not terminate.

Sample Input
3 3 2 16
3 7 2 16
7 3 2 16
3 4 2 16
0 0 0 0

Sample Output
0
2
32766
FOREVER

Source
CTU Open 2004

题目分析:

解线性同余方程:

首先这道题的方程很容易得到

a+cy == b ( mod (1<<k) )

那么化成一般形式就是

a+cx +(1<<k)y = b - a

然后求取d=gcd(c,(1<<k) ),然后如果d|(b-a)不成立,那么无解

如果成立,被d除,之后,利用欧几里得求解之后得到一个解,

然后*d得到一个正解,然后模上(1<<k)/d,获得最小整数解,因为解的集合为x=x1+(1<<k)/d*i ( 0<= 0 < d )

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>

using namespace std;

typedef long long LL;

LL a,b,c,k;

void exgcd ( LL a , LL b , LL& d , LL& x , LL&y )
{
    if ( !b )
        d = a , x = 1 , y = 0;
    else
        exgcd ( b , a%b , d , y , x ) , y -= x*(a/b);
}

LL f ( LL  a , LL b , LL m )
{
    LL d,x,y;
    exgcd ( a, m , d , x , y );
    if ( b % d )
        return -1;
    x = (x*(b/d)%m + m )%m;
    x = (x+(m/d))%(m/d);
    return x;
}

int main ( )
{
    while ( ~scanf ( "%lld%lld%lld%lld" , &a , &b , &c , &k ) )
    {
        if ( !a && !b && !c && !k ) break;
        LL temp = f ( c , b-a , (LL)1<<k );
        if ( temp == -1 )
            puts ( "FOREVER" );
        else printf ( "%lld\n" , temp );
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: