您的位置:首页 > 其它

POJ1328 Radar Installation 貪心

2015-04-16 10:31 351 查看
Description
Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d
distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write
a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.



Figure A Sample Input of Radar Installations

Input
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is
followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

Output
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
Sample Input
3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output
Case 1: 2
Case 2: 1

Source
Beijing 2002

題目大意:在x軸上建設最少的雷達,覆蓋海上的島嶼。

解題思路:考慮每個島嶼若要被覆蓋,則雷達需要建設的範圍。算出每一個島嶼的可建設雷達範圍,進行一次排序(以每個島嶼範圍最佐邊爲排序依據)。因爲每個島嶼必須被覆蓋,所以就某一個島嶼來說,在它被覆蓋在前提下,盡可能的加進去更多的島嶼。所以按照排好的順序枚舉每個島嶼,應用貪心策勵便可計算出答案。 但是要注意一點(在加入新的島嶼時,需要更新這次的右範圍)(博主就是因爲這點wa了幾次,找題解才知道錯因,好悲哀的小菜鳥呀)。

#include <iostream>
#include <cstdlib>
#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;

const int maxn = 1e3 + 5;
struct node{
    double s, t;
    bool operator < (const node &a) const {
        return s < a.s;
    }
} nodes[maxn];

int main()
{
    int n, d;
    int kase = 1;
    while(scanf("%d%d", &n, &d) == 2 && (n || d)) {
        int ok = 1;
        int x, y;
        for(int i = 0; i < n; ++i) {
            scanf("%d%d", &x, &y);
            if(y > d) {ok = 0; continue;}
            nodes[i].s = (double)x - sqrt(d*d - y*y);
            nodes[i].t = (double)x + sqrt(d*d - y*y);
        }
        if(!ok) {printf("Case %d: -1\n", kase++); continue;}
        sort(nodes, nodes+n);
        double tag = nodes[0].t;
        int ans = 1;
        for(int i = 0; i < n; ++i) {
            if(nodes[i].s <= tag) {tag = min(tag, nodes[i].t); continue;}
            else {ans++; tag = nodes[i].t;}
        }
        printf("Case %d: %d\n", kase++, ans);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: