您的位置:首页 > 其它

HDU 5194 DZY Loves Balls(概率)

2015-04-15 23:20 323 查看
Problem Description:

There are n
black balls and m
white balls in the big box.

Now, DZY starts to randomly pick out the balls one by one. It forms a sequence
S.
If at the i-th
operation, DZY takes out the black ball, Si=1,
otherwise Si=0.

DZY wants to know the expected times that '01' occurs in
S.

Input:

The input consists several test cases. (TestCase≤150)

The first line contains two integers, n,
m(1≤n,m≤12)

Output:

For each case, output the corresponding result, the format is
p/q(p
and q
are coprime)

Sample Input:

1 1

2 3

Sample Output:

1/2

6/5

#include <iostream>
#include <cstring>
#include <cstdlib>
#include <cstdio>
#include <vector>
#include <queue>
#include <stack>
#include <set>
#include <map>
using namespace std;
const int MAXN = 1000 + 10;
int n, m;
int gcd(int a, int b)
{
return b == 0 ? a : gcd(b, a % b);
}
int main()
{
while(scanf("%d%d", &n, &m)!=EOF)
{
int c = gcd(n*m, n + m);
printf("%d/%d\n", n*m/c, (n+m)/c);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM 概率 HDU