您的位置:首页 > 大数据 > 人工智能

hdu 1021 Fibonacci Again(同余模定理+斐波那契数列)

2015-04-15 18:11 405 查看

Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 42136 Accepted Submission(s): 20151



Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).



Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).



Output
Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.



Sample Input
0
1
2
3
4
5




Sample Output
no
no
yes
no
no
no




Author
Leojay
题目分析:

递推的时候模3,然后判断时只有f[i]==0的时候才能被整除

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#define MAX 1000007

using namespace std;

int f[MAX];
int n;

int main ( )
{
    f[0] = 7%3 , f[1] = 11%3;
    for ( int i = 2 ; i <= 1000000 ; i++ )
        f[i] = (f[i-1] + f[i-2] )%3;
    while ( ~scanf ( "%d" , &n ) )
        if ( f
 ) puts ( "no" );
        else puts ( "yes" );
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: