您的位置:首页 > 产品设计 > UI/UE

HDU 1159 Common Subsequence

2015-04-15 17:29 246 查看


Common Subsequence

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 26150 Accepted Submission(s): 11613



Problem Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2,
..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length
common subsequence of X and Y.

The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard
output the length of the maximum-length common subsequence from the beginning of a separate line.



Sample Input

abcfbc abfcab
programming contest 
abcd mnp




Sample Output

4
2
0




Source

Southeastern Europe 2003


分析:
求最长公共子序列,状态转移方程:
if(ch1[ i ] == ch2[ j ])

f[ i ][ j ] = f[i - 1][j - 1] + 1;

else

f[ i ][ j ] = max(f[i - 1][ j ], f[ i ][j - 1]);

f[ i ][ j ] 为当第一个字符串遍历到位置 i ,第二个字符串遍历到位置 j 时的最长公共子序列长度。
对于第一组样例,状态转移图如下:



代码:
#include <cstdio>
#include <cstring>
#include <cmath>
#include <iostream>
#include <algorithm>
using namespace std;

const int maxn = 1e3 + 5;
int f[maxn][maxn];
char ch1[maxn], ch2[maxn];

int main()
{
    int len1, len2;
    ch1[0] = ch2[0] = ' ';
    while(~scanf("%s%s", &ch1[1], &ch2[1])) {       //从下标 1 开始读入,便于写状态转移方程
        memset(f, 0, sizeof(f));
        len1 = strlen(ch1);
        len2 = strlen(ch2);
        for(int i = 1; i < len1; i++) {
            for(int j = 1; j < len2; j++) {
                if(ch1[i] == ch2[j])                //当前字符相同,由坐上角转移而得
                    f[i][j] = f[i - 1][j - 1] + 1;
                else                                    //字符不同,取上边和左边较大的
                    f[i][j] = max(f[i - 1][j], f[i][j - 1]);    //上边和左边相同时取上边的
            }
        }
        cout << f[len1 - 1][len2 - 1] << endl;
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: