您的位置:首页 > 其它

poj-1836-Alignment解题报告 LIS

2015-04-14 21:54 465 查看

题目点我
Alignment

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 13887 Accepted: 4493
Description
In the army, a platoon is composed by n soldiers. During the morning inspection, the soldiers are aligned in a straight line in front of the captain. The captain is not satisfied with the way his soldiers are aligned; it is true
that the soldiers are aligned in order by their code number: 1 , 2 , 3 , . . . , n , but they are not aligned by their height. The captain asks some soldiers to get out of the line, as the soldiers that remain in the line, without changing their places, but
getting closer, to form a new line, where each soldier can see by looking lengthwise the line at least one of the line's extremity (left or right). A soldier see an extremity if there isn't any soldiers with a higher or equal height than his height between
him and that extremity.

Write a program that, knowing the height of each soldier, determines the minimum number of soldiers which have to get out of line.

Input
On the first line of the input is written the number of the soldiers n. On the second line is written a series of n floating numbers with at most 5 digits precision and separated by a space character. The k-th number from this
line represents the height of the soldier who has the code k (1 <= k <= n).

There are some restrictions:

• 2 <= n <= 1000

• the height are floating numbers from the interval [0.5, 2.5]

Output
The only line of output will contain the number of the soldiers who have to get out of the line.
Sample Input
8
1.86 1.86 1.30621 2 1.4 1 1.97 2.2

Sample Output
4

Source
Romania OI 2002

正着LIS,反着LIS,最后枚举答案。
LIS:
初始化dp[I]=1,dp[I]表示以i结束的最大上升子序列(注意并不是全局最大),dp[I]=max(dp[I], dp[j]+1)    j<I, a[j]<a[I]。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int n;
double h[1007];
int dp1[1007], dp2[1007];
int ans;
void solve()
{
for(int i=0;i<n+4;i++){
dp1[i]=1;
dp2[i]=1;
}
for(int i=0;i<n;i++){
for(int j=0;j<i;j++){
if(h[j]<h[i]){
dp1[i]=max(dp1[i], dp1[j]+1);
}
}
}
for(int i=n-1;i>=0;i--){
for(int j=n-1;j>i;j--){
if(h[j]<h[i]){
dp2[i]=max(dp2[i], dp2[j]+1);
}
}
}
ans=dp1[0]+dp2[1];
for(int i=1;i<n;i++){
for(int j=i+1;j<n;j++)
ans=max(ans, dp1[i]+dp2[j]);
}
printf("%d\n", n-ans);
}
int main()
{
while(scanf("%d", &n)!=EOF){
for(int i=0;i<n;i++){
scanf("%lf", &h[i]);
}
solve();
}
return 0;
}

据说这道题的数据很逗,体会一下思路就可以了。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: