您的位置:首页 > 其它

hdu 1115 Lifting the Stone(求取多边形的重心)

2015-04-14 14:23 387 查看

Lifting the Stone

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 5924 Accepted Submission(s): 2471



Problem Description
There are many secret openings in the floor which are covered by a big heavy stone. When the stone is lifted up, a special mechanism detects this and activates poisoned arrows that are shot near the opening. The only possibility is
to lift the stone very slowly and carefully. The ACM team must connect a rope to the stone and then lift it using a pulley. Moreover, the stone must be lifted all at once; no side can rise before another. So it is very important to find the centre of gravity
and connect the rope exactly to that point. The stone has a polygonal shape and its height is the same throughout the whole polygonal area. Your task is to find the centre of gravity for the given polygon.



Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer N (3 <= N <= 1000000) indicating the number of points that form
the polygon. This is followed by N lines, each containing two integers Xi and Yi (|Xi|, |Yi| <= 20000). These numbers are the coordinates of the i-th point. When we connect the points in the given order, we get a polygon. You may assume that the edges never
touch each other (except the neighboring ones) and that they never cross. The area of the polygon is never zero, i.e. it cannot collapse into a single line.



Output
Print exactly one line for each test case. The line should contain exactly two numbers separated by one space. These numbers are the coordinates of the centre of gravity. Round the coordinates to the nearest number with exactly two
digits after the decimal point (0.005 rounds up to 0.01). Note that the centre of gravity may be outside the polygon, if its shape is not convex. If there is such a case in the input data, print the centre anyway.



Sample Input
2
4
5 0
0 5
-5 0
0 -5
4
1 1
11 1
11 11
1 11




Sample Output
0.00 0.00
6.00 6.00




Source
Central Europe 1999

题目分析:

模板题,求取多边形的重心

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>

using namespace std;

struct Point
{
    double x,y;
    Point ( ) {}
    Point ( double a , double b )
        : x ( a ) , y ( b ) { }
};

double area ( Point p0 , Point p1 , Point p2 )
{
    double a = 0;
    a = p0.x *p1.y + p1.x * p2.y + p2.x *p0.y  - p1.x*p0.y - p2.x*p1.y - p0.x*p2.y;
    return a/2;
}
//点数较多,在求取过程中读取多边形
Point centreOfGravity ( int n )
{
    double sum_x,sum_y,sum_area;
    sum_x = sum_y = sum_area = 0;
    Point p0,p1,p2;
    scanf ( "%lf%lf" , &p0.x , &p0.y );
    scanf ( "%lf%lf" , &p1.x , &p1.y );
    for ( int i = 2 ; i < n ; i++ )
    {
        scanf ( "%lf%lf" , &p2.x , &p2.y );
        double a = area ( p0 , p1 , p2 );
        sum_area += a;
        sum_x += ( p0.x + p1.x + p2.x ) * a;
        sum_y += ( p0.y + p1.y + p2.y ) * a;
        p1 = p2;
    }
    return Point ( sum_x/sum_area/3 , sum_y/sum_area /3 );
}

int t,n;

int main ( )
{
    scanf ( "%d" , &t );
    while ( t-- )
    {
        scanf ( "%d" , &n );
        Point ans = centreOfGravity ( n );
        printf ( "%.2lf %.2lf\n" , ans.x , ans.y );
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: