您的位置:首页 > 其它

题目1145:Candy Sharing Game

2015-04-13 17:14 260 查看
题目描述:
A number of students sit in a circle facing their teacher in the center. Each student initially has an even number of pieces of candy. When the teacher blows a whistle, each student simultaneously gives half of his or her candy to the neighbor on the
right. Any student, who ends up with an odd number of pieces of candy, is given another piece by the teacher. The game ends when all students have the same number of pieces of candy.

Write a program which determines the number of times the teacher blows the whistle and the final number of pieces of candy for each student from the amount of candy each child starts with.

输入:
The input may describe more than one game. For each game, the input begins with the number N of students,followed by N (even) candy counts for the children counter-clockwise around the circle. The input ends with a student count of 0. Each input number
is on a line by itself.

输出:
For each game, output the number of rounds of the game followed by the amount of candy each child ends up with,both on one line.

样例输入:
6
36
2
2
2
2
2
11
22
20
18
16
14
12
10
8
6
4
2
4
2
4
6
8
0


样例输出:
15 14
17 22
4 8


提示:
The game ends in a finite number of steps because:

1. The maximum candy count can never increase.

2. The minimum candy count can never decrease.

3. No one with more than the minimum amount will ever decrease to the minimum.

4. If the maximum and minimum candy count are not the same, at least one student with the minimum amount must have their count increase

来源:
2009年北京大学计算机研究生机试真题

#include<stdio.h>
int a[1000],b[1000];
int main(){
int n,i;
while(scanf("%d",&n)!=EOF){
if(n==0)
break;
int count=0,k=1,signal=0;
for(i=0;i<n;i++)
scanf("%d",&a[i]);
while(signal!=1){
for(i=0;i<n;i++){
a[i]=a[i]/2;
if(i==n-1)
b[0]=a[i];
else
b[k++]=a[i];
}
for(i=0;i<n;i++){
a[i]=a[i]+b[i];
if(a[i]%2==1)
a[i]++;
}
count++;//进行的次数
int t=0;
for(i=0;i<n;i++){
if(a[i]==a[0])
t++;
}
if(t==n){
signal=1;
}
k=1;
}
printf("%d %d\n",count,a[0]);

}
return 0;
}
/**************************************************************
Problem: 1145
User: Carvin
Language: C++
Result: Accepted
Time:10 ms
Memory:1028 kb
****************************************************************/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: