您的位置:首页 > 其它

hdoj.1003 Max Sum【DP】 2015/04/13

2015-04-13 12:27 274 查看

Max Sum

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 164629 Accepted Submission(s): 38547

[align=left]Problem Description[/align]
Given a sequence a[1],a[2],a[3]......a
, your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

[align=left]Input[/align]
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and
1000).

[align=left]Output[/align]
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end
position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

[align=left]Sample Input[/align]

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5


[align=left]Sample Output[/align]

Case 1:
14 1 4

Case 2:
7 1 6
#include<stdio.h>
struct node{
int num;
int sum;
int beg,end;
}dp[100001];
int main(){
int t,m,n,i,j;
scanf("%d",&t);
for( n=1 ; n <= t; ++n ){
scanf("%d",&m);
for(i=1;i<=m;++i)
scanf("%d",&dp[i].num);
dp[0].num = dp[0].sum = dp[0].beg = dp[0].end = -1;
i = 1;
while( i <= m ){
if( dp[i-1].sum < 0 ){
dp[i].beg = dp[i].end = i;
dp[i].sum = dp[i].num;
}
else{
if( dp[i].num + dp[i-1].sum < 0 ){
dp[i].sum = -1;
dp[i].beg = dp[i].end = i;
}
else {
dp[i].sum = dp[i].num + dp[i-1].sum;
dp[i].beg = dp[i-1].beg;
dp[i].end = i;
}
}
++i;
}
int max = -1000000,flag;
for(i=1;i<=m;++i)
if( max < dp[i].sum ){
flag = i;
max = dp[i].sum;
}
if( n>1 ) printf("\n");
printf("Case %d:\n",n);
printf("%d %d %d\n",max,dp[flag].beg,dp[flag].end);
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: