您的位置:首页 > 其它

浙江大学PAT_甲级_1005.1005. Spell It Right (20)

2015-04-11 20:55 567 查看
题目链接:http://www.patest.cn/contests/pat-a-practise/1005

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (<= 10100).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.
Sample Input:
12345

Sample Output:
one five

我的c++程序:

#include<iostream>
#include<stack>
#include<string>
using namespace std;
int main()
{
string n;
string out[10] = { "zero", "one", "two", "three", "four", "five", "six", "seven", "eight", "nine"};
int i=0;
int sum = 0;
stack<int> st;
cin >> n;
while (i<n.length())//char 转int,计算n各位数字之和
{
sum = n[i] - '0' + sum;
i++;
}
if (sum == 0)//如果和为0,直接输出
{
cout << "zero";
}
while (sum != 0)
{
st.push(sum % 10);//取余数进栈
sum = sum / 10;
}
int flag = 1;
while (!st.empty())
{
if (flag == 1)
{
cout << out[st.top()] ;//第一个输出的字符串
flag = 0;
}
else
{
cout << ' ' << out[st.top()];//后面的字符串不带空格
}
st.pop();
}
//system("pause");
return 0;
}



[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: