您的位置:首页 > 其它

POJ 1046 Color Me Less

2015-04-10 20:55 309 查看
Color Me Less

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 31449Accepted: 15309
Description

A color reduction is a mapping from a set of discrete colors to a smaller one. The solution to this problem requires that you perform just such a mapping in a standard twenty-four bit RGB color space. The input consists of a target set of sixteen RGB color
values, and a collection of arbitrary RGB colors to be mapped to their closest color in the target set. For our purposes, an RGB color is defined as an ordered triple (R,G,B) where each value of the triple is an integer from 0 to 255. The distance between
two colors is defined as the Euclidean distance between two three-dimensional points. That is, given two colors (R1,G1,B1) and (R2,G2,B2), their distance D is given by the equation



Input

The input is a list of RGB colors, one color per line, specified as three integers from 0 to 255 delimited by a single space. The first sixteen colors form the target set of colors to which the remaining colors will be mapped. The input is terminated by a line
containing three -1 values.
Output

For each color to be mapped, output the color and its nearest color from the target set.

If there are more than one color with the same smallest distance, please output the color given first in the color set.
Sample Input
0 0 0
255 255 255
0 0 1
1 1 1
128 0 0
0 128 0
128 128 0
0 0 128
126 168 9
35 86 34
133 41 193
128 0 128
0 128 128
128 128 128
255 0 0
0 1 0
0 0 0
255 255 255
253 254 255
77 79 134
81 218 0
-1 -1 -1

Sample Output
(0,0,0) maps to (0,0,0)
(255,255,255) maps to (255,255,255)
(253,254,255) maps to (255,255,255)
(77,79,134) maps to (128,128,128)
(81,218,0) maps to (126,168,9)


题目大意:在三维空间坐标系里给出16个固定的点,然后接下来在每给出一个点,在这16个点中找出一个离该点最近的点。
有多个时,按16点的输入顺序输出最靠前的那个。

#include <stdio.h>
#include <string.h>
#include <math.h>

struct pp
{
int r,g,b;
}s[20];

double dis(pp s1,pp s2)
{
return sqrt((double)(s1.r-s2.r)*(s1.r-s2.r)+(s1.g-s2.g)*(s1.g-s2.g)+(s1.b-s2.b)*(s1.b-s2.b));
}

int main()
{
int i,j,k,n;
double sum;
for(i=1;i<=16;i++)
scanf("%d%d%d",&s[i].r,&s[i].g,&s[i].b);
while(scanf("%d%d%d",&s[0].r,&s[0].g,&s[0].b))
{
if(s[0].r==-1 && s[0].g==-1 && s[0].b==-1)
break;
sum=dis(s[0],s[1]);k=1;
for(i=2;i<=16;i++)
if(sum-dis(s[0],s[i])>0)
{
k=i;sum=dis(s[0],s[i]);
}
printf("(%d,%d,%d) maps to (%d,%d,%d)\n",s[0].r,s[0].g,s[0].b,s[k].r,s[k].g,s[k].b);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: