您的位置:首页 > 其它

poj1003

2015-04-10 17:01 169 查看
题目描述:

Hangover

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 107228Accepted: 52294
Description

How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We're assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the
bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2
+ 1/3 = 5/6 card lengths. In general you can make n cards overhang by 1/2
+ 1/3 + 1/4 + ... + 1/(n + 1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs
the table by 1/(n + 1). This is illustrated in the figure below.



Input
The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least
0.01 and at most 5.20; c will contain exactly three digits.
Output
For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.
Sample Input
1.00
3.71
0.04
5.19
0.00

Sample Output
3 card(s)
61 card(s)
1 card(s)
273 card(s)

代码:
#include <iostream>
using namespace std;
const double delta = 1e-8;

const int MAXSIZE = 300;

int zero(double x)          //判断一个浮点数是否为零
{
    if (x < -delta)
        return -1;
    else
        return x > delta;
}

int createTable(double *t)        //计算离线表
{
    t[0] = 0.0;
    int i = 0;
    while ( ( zero(t[i] - 5.20) < 0) )
    {
        double next = t[i] + 1 / (double)(i + 2);
        t[++i] = next;
    }
    return i;
}

int main()
{
    double tbl[MAXSIZE];
    int total = createTable(tbl);

    double in;
    while (1)
    {
        cin >> in;
        if ( zero(in) == 0 )
            break;

        int l = 0;
        int r = total;
        int mid;
        while ( l + 1 != r)
        {
            mid = (l+r) / 2;
            if ( zero(in - tbl[mid] ) > 0 )
                l = mid;
            else if ( zero(in - tbl[mid]) < 0 )
                r = mid;

        }
        cout << r << " card(s)\n";
    }

}

总结:
1)判断一个实数是否等于0,不能直接和0比较,规定在一个较小的范围(这里为:1e-8 ~ -(1e-8))内即为0。
2)使用二分法在数组中寻找第一个大于指定数的元素索引。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: