您的位置:首页 > 其它

ZOJ 3822 Domination 概率DP求期望

2015-04-09 09:40 369 查看
Domination

Time Limit: 8 Seconds Memory Limit: 131072 KB Special Judge

Edward is the headmaster of Marjar University. He is enthusiastic about chess and often plays chess with his friends. What's more, he bought a large decorative chessboard with N rows and M columns.

Every day after work, Edward will place a chess piece on a random empty cell. A few days later, he found the chessboard was dominated by the chess pieces. That means there is at least one chess piece in every row. Also, there is at least one chess
piece in every column.

"That's interesting!" Edward said. He wants to know the expectation number of days to make an empty chessboard of N × M dominated. Please write a program to help him.


Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There are only two integers N and M (1 <= N, M <= 50).


Output

For each test case, output the expectation number of days.

Any solution with a relative or absolute error of at most 10-8 will be accepted.


Sample Input

2
1 3
2 2


Sample Output

3.000000000000
2.666666666667


#include <iostream>
#include <stdio.h>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>

using namespace std;

double dp[55][55][2555];
int n,m;
int T;

int main()
{
    while(~scanf("%d",&T))
    {
        while(T--)
        {
            scanf("%d %d",&n,&m);
            int sum=n*m;

            memset(dp,0,sizeof dp);

            dp[0][0][0]=1;

            for(int k=1;k<=sum;k++)
            {
                for(int i=1;i<=n;i++)
                {
                    for(int j=1;j<=m;j++)
                    {
                        dp[i][j][k]+=(dp[i][j][k-1]*(i*j-k+1)/(sum-k+1));//行列都不增加
                        dp[i][j][k]+=(dp[i-1][j-1][k-1]*(n-i+1)*(m-j+1)/(sum-k+1));//行列都增加
                        dp[i][j][k]+=(dp[i-1][j][k-1]*(n-i+1)*j/(sum-k+1));//只增加行
                        dp[i][j][k]+=(dp[i][j-1][k-1]*(m-j+1)*i/(sum-k+1));//只增加列
                    }
                }
            }

            double ans=0;
            for(int k=1;k<=sum;k++)
            {
                ans+=(dp
[m][k]-dp
[m][k-1])*k;//期望
            }

            printf("%.10lf\n",ans);

        }
    }

    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: