您的位置:首页 > 其它

hdu 1217 Arbitrage(最短路--floyd+对数的性质)

2015-04-09 08:43 288 查看

Arbitrage

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 5106 Accepted Submission(s): 2338



Problem Description
Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys
10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.



Input
The input file will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within
a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name
cj of the destination currency. Exchanges which do not appear in the table are impossible.

Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.



Output
For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".



Sample Input
3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0




Sample Output
Case 1: Yes
Case 2: No




Source
University of Ulm Local Contest 1996

题目分析:

对数可以将乘法的操作,转换为加法操作,也就对值取对数,然后求最大路,最后判断到自己的环的是否大于0,初值赋为0(log1==0)

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <string>
#include <map>
#include <cmath>
#define MAX 37

using namespace std;

int n,m;
double dis[MAX][MAX],v;
map<string,int> mp;
char s[500];

int main ( )
{
    int c = 1;
    while ( ~scanf ( "%d" , &n ) ,n )
    {
        mp.clear();
        memset ( dis , -0x3f , sizeof ( dis ) );
        for ( int i = 0 ; i < n ; i++ )
        {
            scanf ( "%s" , s );
            mp[s] = i;
            dis[i][i] = 0;
        }
        scanf ( "%d" , &m );     
        for ( int i = 0 ; i < m ; i++ )
        {
            scanf ( "%s" , s );
            int x = mp[s];
            scanf ( "%lf" , &v );
            scanf ( "%s" , s );
            v = log(v);
            int y = mp[s];   
            dis[x][y] = max ( dis[x][y] , v );
        }
        for ( int k = 0 ; k < n ; k++ )
            for ( int i = 0 ; i < n ; i++ )
                for  ( int j = 0 ; j < n ; j++ )
                        dis[i][j] = max ( dis[i][j] , dis[i][k] + dis[k][j] );
        bool ans = false;
        for ( int i = 0 ; i < n ; i++ )
            if ( dis[i][i] > 0 ) ans = true;
        printf ( "Case %d: " , c++ );
        if ( ans ) puts ( "Yes" );
        else puts ( "No" );
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: