您的位置:首页 > 其它

Leftmost Digit(数学)

2015-04-07 20:32 169 查看


Leftmost Digit

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 14322 Accepted Submission(s): 5479



Problem Description

Given a positive integer N, you should output the leftmost digit of N^N.



Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains a single positive integer N(1<=N<=1,000,000,000).



Output

For each test case, you should output the leftmost digit of N^N.



Sample Input

2
3
4




Sample Output

2
2

Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2.
In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.




Author

Ignatius.L



Recommend

We have carefully selected several similar problems for you: 1071 1573 1066 1065 1788



/*
m=n^n;
log10(m)=log10(n^n);
log10(m)=n*log10(n);
m=10^(n*log10(n))
设b=n*log10(n);
注意公式10^(a+b)=10^a*10^b我们假设这里a是整数b是小数
我们知道10的整数次方的第一位是1,所以要去全局的第一位肯定和有关*/
#include<stdio.h>
#include<math.h>
int main()
{
    int times;
    double b,a,n;
    scanf("%d",×);
    while(times--)
    {
        scanf("%lf",&n);
        b=n*log10(n);
        a=b-(long long)b;
        printf("%d\n",(int)pow(10,a));
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: