您的位置:首页 > 其它

HDU 1159

2015-04-07 20:19 302 查看

Common Subsequence

Problem Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, …, xm > another sequence Z = < z1, z2, …, zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, …, ik > of indices of X such that for all j = 1,2,…,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc abfcab

programming contest

abcd mnp

Sample Output

4

2

0

题解:

经典动态规划,最长公共子序列。

动态转移方程:

if(a[i-1]==b[j-1])
{
f[i][j]=f[i-1][j-1]+1;
}
else f[i][j]=max(f[i][j-1],f[i-1][j]);


源代码:

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
int maxx(int a,int b)
{
return a>b?a:b;
}
int main()
{
char a[502],b[502];
int i,j,k;
int f[502][502];
while(scanf("%s%s",a,b)!=EOF)
{
int lena,lenb;
lena=strlen(a);
//printf("%d--\n",lena);
lenb=strlen(b);
//printf("%d---\n",lenb);
memset(f,0,sizeof(f));
for(i=1;i<=lena;i++)
{
for(j=1;j<=lenb;j++)
{
if(a[i-1]==b[j-1])
{
f[i][j]=f[i-1][j-1]+1;
}
else f[i][j]=maxx(f[i][j-1],f[i-1][j]);
}
}
printf("%d\n",f[lena][lenb]);
}
return 0;
}


我的gitcafe blog地址:8cbx.gitcafe.io
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  hdu ACM 题解