您的位置:首页 > 其它

HEU日常训练10.02

2015-04-07 20:17 393 查看
这套题就看了两道,先发上来这两个最水的题解

第一题

H - H

Time Limit:3000MS Memory Limit:0KB

Description

Trung is bored with his mathematics homeworks. He takes a piece of chalk and starts writing a sequence of consecutive integers starting with 1 to N(1 < N < 10000) . After that, he counts the number of times each digit (0 to 9) appears in the sequence. For example, with N = 13 , the sequence is:

12345678910111213

In this sequence, 0 appears once, 1 appears 6 times, 2 appears 2 times, 3 appears 3 times, and each digit from 4 to 9 appears once. After playing for a while, Trung gets bored again. He now wants to write a program to do this for him. Your task is to help him with writing this program.

Input

The input file consists of several data sets. The first line of the input file contains the number of data sets which is a positive integer and is not bigger than 20. The following lines describe the data sets.

For each test case, there is one single line containing the number N .

Output

For each test case, write sequentially in one line the number of digit 0, 1,…9 separated by a space.

Sample Input

2

3

13

Sample Output

0 1 1 1 0 0 0 0 0 0

1 6 2 2 1 1 1 1 1 1

思路:

枚举加统计

代码:

#include<stdio.h>
int freq[10];
void count(int n)
{
do
{
freq[n%10]++;
n/=10;
}while(n!=0);
}
int main()
{
int i,t,n;
scanf("%d",&t);
while(t--)
{
for (i=0;i<10;i++)
freq[i]=0;
scanf("%d",&n);
for (i=1;i<=n;i++)
count(i);
for (i=0;i<10;i++)
if (i!=9)
printf("%d ",freq[i]);
else
printf("%d\n",freq[i]);
}
return 0;
}


第二题

J - J

Time Limit:2000MS Memory Limit:262144KB

Description

Little Vasya has received a young builder’s kit. The kit consists of several wooden bars, the lengths of all of them are known. The bars can be put one on the top of the other if their lengths are the same.

Vasya wants to construct the minimal number of towers from the bars. Help Vasya to use the bars in the best way possible.

Input

The first line contains an integer N (1 ≤ N ≤ 1000) — the number of bars at Vasya’s disposal. The second line contains N space-separated integers li — the lengths of th无标题文档e bars. All the lengths are natural numbers not exceeding 1000.

Output

In one line output two numbers — the height of the largest tower and their total number. Remember that Vasya should use all the bars.

Sample Input

Input

3

1 2 3

Output

1 3

Input

4

6 5 6 7

Output

2 3

思路:

排序加统计

代码:

#include <iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;

int main()
{
int n,i,j,temp;
int a[1001];
int max;
int sum;
sum=0;
scanf("%d",&n);
for(i=0;i<n;i++)
{
scanf("%d",&a[i]);
}
for(i=0;i<n;i++)
{
for(j=i+1;j<n;j++)
{
if(a[j]<a[i])
{
temp=a[j];
a[j]=a[i];
a[i]=temp;
}
}
}
max=1;
for(i=0;i<n;i++)
{
sum++;
temp=1;
for(j=i+1;j<n;j++)
{
if(a[j]==a[i])
{
temp++;
}
else
{
break;
}
}
if(temp>max)
{
max=temp;
}
i=j-1;
}
printf("%d %d\n",max,sum);
return 0;
}


我的gitcafe blog地址:8cbx.gitcafe.io
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM 题解