您的位置:首页 > 其它

hdu 3579 Hello Kiki(线性同余方程)

2015-04-07 00:38 211 查看


Hello Kiki

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2336 Accepted Submission(s): 860



Problem Description

One day I was shopping in the supermarket. There was a cashier counting coins seriously when a little kid running and singing "门前大桥下游过一群鸭,快来快来 数一数,二四六七八". And then the cashier put the counted coins back morosely and count again...

Hello Kiki is such a lovely girl that she loves doing counting in a different way. For example, when she is counting X coins, she count them N times. Each time she divide the coins into several same sized groups and write down the group size Mi and the number
of the remaining coins Ai on her note.

One day Kiki's father found her note and he wanted to know how much coins Kiki was counting.



Input

The first line is T indicating the number of test cases.

Each case contains N on the first line, Mi(1 <= i <= N) on the second line, and corresponding Ai(1 <= i <= N) on the third line.

All numbers in the input and output are integers.

1 <= T <= 100, 1 <= N <= 6, 1 <= Mi <= 50, 0 <= Ai < Mi



Output

For each case output the least positive integer X which Kiki was counting in the sample output format. If there is no solution then output -1.



Sample Input

2
2
14 57
5 56
5
19 54 40 24 80
11 2 36 20 76




Sample Output

Case 1: 341
Case 2: 5996




因为要求的最小的正整数解 所以如果求得r1的值为0 输出a1(最小公倍数)

#include <cstdio>
#include <iostream>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <string.h>
#include <string>
#include <vector>
#include <queue>

#define MEM(a,x) memset(a,x,sizeof a)
#define eps 1e-8
#define MOD 10009
#define MAXN 10010
#define MAXM 100010
#define INF 99999999
#define ll __int64
#define bug cout<<"here"<<endl
#define fread freopen("ceshi.txt","r",stdin)
#define fwrite freopen("out.txt","w",stdout)

using namespace std;

ll Read()
{
    char ch;
    ll a = 0;
    while((ch = getchar()) == ' ' | ch == '\n');
    a += ch - '0';
    while((ch = getchar()) != ' ' && ch != '\n')
    {
        a *= 10;
        a += ch - '0';
    }
    return a;
}

void Prll(ll a)    //输出外挂
{
     if(a>9)
         Prll(a/10);
     putchar(a%10+'0');
}

void Exgcd(ll a,ll b,ll &d,ll &x,ll &y)
{
    if(!b)
    {
        x=1; y=0; d=a;
    }
    else
    {
        Exgcd(b,a%b,d,y,x);
        y-=x*(a/b);
    }
}
int aa[20],r[20];

int main()
{
//    fread;
    int tc;
    scanf("%d",&tc);
    int cs=1;
    while(tc--)
    {
        ll n,m;
        scanf("%I64d",&n);
        for(ll i=1;i<=n;i++)
            scanf("%I64d",&aa[i]);
        for(ll i=1;i<=n;i++)
            scanf("%I64d",&r[i]);
        bool ifhave=1;
        ll a1,a2,r1,r2,ans,a,b,c,d,x0,y0;
        a1=aa[1];r1=r[1];
        for(int i=2;i<=n;i++)
        {
            a2=aa[i]; r2=r[i];
            a=a1; b=a2; c=r2-r1;
            Exgcd(a,b,d,x0,y0);
            if(c%d!=0)
                ifhave=0;
            ll t=b/d;
            x0=(x0*(c/d)%t+t)%t;
            r1=a1*x0+r1;
            a1=a1*(a2/d);
//            r1=(r1%a1+a1)%a1;
        }
        printf("Case %d: ",cs++);
        if(!ifhave)
        {
            puts("-1");
            continue;
        }
        if(r1==0)
            printf("%I64d\n",a1);//因为要输出最小正整数解  所以 输出Mi(a[i])的最小公倍数a1
        else
            printf("%I64d\n",r1);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: