您的位置:首页 > 其它

HDOJ 题目1528 Card Game Cheater(二分图最小点覆盖)

2015-04-06 11:43 375 查看


Card Game Cheater

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 1357 Accepted Submission(s): 722



Problem Description

Adam and Eve play a card game using a regular deck of 52 cards. The rules are simple. The players sit on opposite sides of a table, facing each other. Each player gets k cards from the deck and, after looking at them, places the cards face down in a row on
the table. Adam’s cards are numbered from 1 to k from his left, and Eve’s cards are numbered 1 to k from her right (so Eve’s i:th card is opposite Adam’s i:th card). The cards are turned face up, and points are awarded as follows (for each i ∈ {1, . . . ,
k}):

If Adam’s i:th card beats Eve’s i:th card, then Adam gets one point.

If Eve’s i:th card beats Adam’s i:th card, then Eve gets one point.

A card with higher value always beats a card with a lower value: a three beats a two, a four beats a three and a two, etc. An ace beats every card except (possibly) another ace.

If the two i:th cards have the same value, then the suit determines who wins: hearts beats all other suits, spades beats all suits except hearts, diamond beats only clubs, and clubs does not beat any suit.

For example, the ten of spades beats the ten of diamonds but not the Jack of clubs.

This ought to be a game of chance, but lately Eve is winning most of the time, and the reason is that she has started to use marked cards. In other words, she knows which cards Adam has on the table before he turns them face up. Using this information she orders
her own cards so that she gets as many points as possible.

Your task is to, given Adam’s and Eve’s cards, determine how many points Eve will get if she plays optimally.

Input

There will be several test cases. The first line of input will contain a single positive integer N giving the number of test cases. After that line follow the test cases.

Each test case starts with a line with a single positive integer k <= 26 which is the number of cards each player gets. The next line describes the k cards Adam has placed on the table, left to right. The next line describes the k cards Eve has (but she has
not yet placed them on the table). A card is described by two characters, the first one being its value (2, 3, 4, 5, 6, 7, 8 ,9, T, J, Q, K, or A), and the second one being its suit (C, D, S, or H). Cards are separated by white spaces. So if Adam’s cards are
the ten of clubs, the two of hearts, and the Jack of diamonds, that could be described by the line

TC 2H JD

Output

For each test case output a single line with the number of points Eve gets if she picks the optimal way to arrange her cards on the table.

Sample Input

3
1
JD
JH
2
5D TC
4C 5H
3
2H 3H 4H
2D 3D 4D


Sample Output

1
1
2


Source

Northwestern Europe 2004

Recommend

8600 | We have carefully selected several similar problems for you: 1507 1533 1530 1526 2768

题目意思是给一副扑克牌,点数大小从2-A,T代表的是10,A最大..然后四种花色分别是C、D、S、H,如果点数相同的话C<D<S<H。两个无聊的人开始用这幅52张的扑克牌玩游戏,每次两个人取k张牌,没有两张一模一样的牌,问第二个人可以赢第一个人多少次...

ac代码

#include<stdio.h>
#include<string.h>
int a[1010],b[1010],map[1010][1010],link[1010],vis[1010],n;
int fun(char *s)
{
int ans;
if(s[0]=='T')
ans=10;
else
if(s[0]=='J')
ans=11;
else
if(s[0]=='Q')
ans=12;
else
if(s[0]=='K')
ans=13;
else
if(s[0]=='A')
ans=14;
else
ans=s[0]-'0';
if(s[1]=='C')
ans=ans*10+1;
else
if(s[1]=='D')
ans=ans*10+2;
else
if(s[1]=='S')
ans=ans*10+3;
else
if(s[1]=='H')
ans=ans*10+4;
return ans;
}
int dfs(int x)
{
int i;
for(i=1;i<=n;i++)
{
if(!vis[i]&&map[x][i])
{
vis[i]=1;
if(link[i]==-1||dfs(link[i]))
{
link[i]=x;
return 1;
}
}
}
return 0;
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int i,j;
scanf("%d",&n);
for(i=1;i<=n;i++)
{
char s[10];
scanf("%s",s);
a[i]=fun(s);
}
for(i=1;i<=n;i++)
{
char s[10];
scanf("%s",s);
b[i]=fun(s);
}
memset(map,0,sizeof(map));
for(i=1;i<=n;i++)
{
for(j=1;j<=n;j++)
{
if(a[i]<b[j])
{
map[i][j]=1;
}
}
}
memset(link,-1,sizeof(link));
int ans=0;
for(i=1;i<=n;i++)
{
memset(vis,0,sizeof(vis));
if(dfs(i))
ans++;
}
printf("%d\n",ans);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: