您的位置:首页 > 编程语言 > Go语言

hdu 3635 Dragon Balls(并查集的各种应用)

2015-04-05 22:27 295 查看

Dragon Balls

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3748 Accepted Submission(s): 1448



Problem Description
Five hundred years later, the number of dragon balls will increase unexpectedly, so it's too difficult for Monkey King(WuKong) to gather all of the dragon balls together.



His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities' dragon ball(s) would be transported to other cities. To save physical
strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls.

Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the
ball has been transported so far.


Input
The first line of the input is a single positive integer T(0 < T <= 100).

For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000).

Each of the following Q lines contains either a fact or a question as the follow format:

T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different.

Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)


Output
For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.


Sample Input
2
3 3
T 1 2
T 3 2
Q 2
3 4
T 1 2
Q 1
T 1 3
Q 1




Sample Output
Case 1:
2 3 0
Case 2:
2 2 1
3 3 2




Author
possessor WC


Source

题目分析:并查集的各种利用,首先是将同一个城市的龙珠看成一个集合,利用并查集做集合并,另外就是利用并查集的递归统计转移次数并且记录每个位置的龙珠的个数

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#define MAX 10007

using namespace std;

int fa[MAX];
int sum[MAX];
int num[MAX];

void init ( int n )
{
    for ( int i = 0 ; i <= n ; i++ )
        fa[i] = i , sum[i] = 0 , num[i] = 1;
}

int find ( int x )
{
    if ( x == fa[x] ) return x;
    else
    {
        int temp = find ( fa[x] );
        sum[x] += sum[fa[x]];
        return fa[x] = temp;
    }
}

int t,n,q;
char s[5];

int main ( )
{
    int a,b;
    scanf ( "%d" , &t );
    int c = 1;
    while ( t-- )
    {
        scanf ( "%d%d" , &n , &q );
        init( n );
        printf ( "Case %d:\n" , c++ );
        for ( int i = 0 ; i < q ; i++ )
        {
            scanf ( "%s" , s );
            if ( s[0] == 'T' )
            {
                scanf ( "%d%d" , &a , &b );
                int x = find ( b );
                int y = find ( a );
                sum[y]++;
                fa[y] = x;
                num[x] += num[y];
            }
            else
            {
                scanf ( "%d" , &a );
                int id = find(a);
                printf ( "%d %d %d\n" , id , num[id] , sum[a] ); 
            }
        }
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: