您的位置:首页 > 其它

hdoj 1078 fatmouse and cheese 记忆化搜索

2015-04-05 21:30 288 查看


FatMouse and Cheese

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 5535 Accepted Submission(s): 2253



Problem Description

FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole.
Now he's going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run
at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks
of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.

Input

There are several test cases. Each test case consists of

a line containing two integers between 1 and 100: n and k

n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on.

The input ends with a pair of -1's.

Output

For each test case output in a line the single integer giving the number of blocks of cheese collected.

Sample Input

3 1
1 2 5
10 11 6
12 12 7
-1 -1


Sample Output

37


我勒个去。。我真是感动的泪流满面,头一次自己写记忆化搜索居然一次就过了。

好吧,可能这道题和之前那道skiing太像了吧。。。唯一变化的就是走的步数,不一定非得是一步,1步到k步都可以。

这样用个循环遍历所有走的步数就可以了,就是把从前四个方向的一重循环改成外循环是方向内循环是步数。

搜索过的点不用再继续搜,直接返回从这个点出发能收集的最大奶酪数。

这样某一个点的最大奶酪数就是从这个点出发,4*k种可能(4个方向,k个步数)中最大的那个。

#include <iostream>
#include <stdio.h>
#include <algorithm>
using namespace std;
int dp[105][105], a[105][105], dirx[4] = {1,-1,0,0}, diry[4] = {0,0,1,-1}, n, k, vis[105][105];
int dfs(int x, int y)
{
int xx, yy, j, p;
if(vis[x][y])
return dp[x][y];
vis[x][y] = 1;
for(j = 0 ; j < 4 ; j++)
for(p = 1 ; p <= k ; p++)
{
xx = x + p*dirx[j];
yy = y + p*diry[j];
if(xx < 1 || yy < 1 || xx > n || yy > n || a[xx][yy] <= a[x][y])
continue;
dp[x][y] = max(dp[x][y], dfs(xx, yy)+a[x][y]);
}
return dp[x][y];
}
int main()
{
int i, j;
while(scanf("%d %d", &n, &k), n!=-1||k!=-1)
{
for(i = 1 ; i <= n ; i++)
for(j = 1 ; j <= n ; j++)
{
scanf("%d", &a[i][j]);
dp[i][j] = a[i][j];
vis[i][j] = 0;
}
printf("%d\n", dfs(1,1));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: