您的位置:首页 > 其它

解线性同余方程的应用

2015-04-05 19:20 225 查看
poj 2891

Strange Way to Express Integers

Time Limit: 1000MSMemory Limit: 131072K
Total Submissions: 10873Accepted: 3324
Description

Elina is reading a book written by Rujia Liu, which introduces a strange way to express non-negative integers. The way is described as following:

Choose k different positive integers a1, a2, …, ak. For some non-negative m, divide it by every ai (1 ≤ i ≤ k) to find
the remainder ri. If a1, a2, …, ak are properly chosen, m can be determined, then the pairs (ai, ri) can be used to express m.

“It is easy to calculate the pairs from m, ” said Elina. “But how can I find m from the pairs?”

Since Elina is new to programming, this problem is too difficult for her. Can you help her?

Input

The input contains multiple test cases. Each test cases consists of some lines.

Line 1: Contains the integer k.
Lines 2 ~ k + 1: Each contains a pair of integers ai, ri (1 ≤ i ≤ k).

Output

Output the non-negative integer m on a separate line for each test case. If there are multiple possible values, output the smallest one. If there are no possible values, output -1.

Sample Input
2
8 7
11 9

Sample Output
31

Hint

All integers in the input and the output are non-negative and can be represented by 64-bit integral types.

Source

POJ Monthly--2006.07.30, Static
模板题 贴个模版
#include <cstdio>
#include <iostream>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <string.h>
#include <string>
#include <vector>
#include <queue>

#define MEM(a,x) memset(a,x,sizeof a)
#define eps 1e-8
#define MOD 10009
#define MAXN 10010
#define MAXM 100010
#define INF 99999999
#define ll __int64
#define bug cout<<"here"<<endl
#define fread freopen("ceshi.txt","r",stdin)
#define fwrite freopen("out.txt","w",stdout)

using namespace std;

int Read()
{
    char ch;
    int a = 0;
    while((ch = getchar()) == ' ' | ch == '\n');
    a += ch - '0';
    while((ch = getchar()) != ' ' && ch != '\n')
    {
        a *= 10;
        a += ch - '0';
    }
    return a;
}

void Print(int a)    //输出外挂
{
     if(a>9)
         Print(a/10);
     putchar(a%10+'0');
}
ll n;
void Exgcd(ll a,ll b,ll &d,ll &x,ll &y)
{
    if(!b)
    {
        x=1; y=0; d=a;
    }
    else
    {
        Exgcd(b,a%b,d,y,x);
        y-=x*(a/b);
    }
}

ll solve()
{
    bool ifhave=1;
    ll a1,r1,a2,r2,a,b,c,d,x0,y0;
    scanf("%lld%lld",&a1,&r1);
    for(ll i=1;i<n;i++)
    {
        scanf("%lld%lld",&a2,&r2);
        a=a1; b=a2; c=r2-r1;
        Exgcd(a,b,d,x0,y0);
        if(c%d!=0)
            ifhave=0;
        ll t=b/d;
        x0=(x0*(c/d)%t+t)%t;
        r1=a1*x0+r1;
        a1=a1*(a2/d);
    }
    if(!ifhave)
        return -1;
    else return r1;
}

int main()
{
    //fread;

    while(scanf("%lld",&n)!=EOF)
    {
        ll res=solve();
        printf("%lld\n",res);
    }
    return 0;
}


poj 2115

C Looooops

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 18974Accepted: 4985
Description

A Compiler Mystery: We are given a C-language style for loop of type

for (variable = A; variable != B; variable += C)

  statement;


I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming
that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2k) modulo 2k.

Input

The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C
< 2k) are the parameters of the loop.

The input is finished by a line containing four zeros.

Output

The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate.

Sample Input
3 3 2 16
3 7 2 16
7 3 2 16
3 4 2 16
0 0 0 0

Sample Output
0
2
32766
FOREVER




#include <cstdio>
#include <iostream>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <string.h>
#include <string>
#include <vector>
#include <queue>

#define MEM(a,x) memset(a,x,sizeof a)
#define eps 1e-8
#define MOD 10009
#define MAXN 10010
#define MAXM 100010
#define INF 99999999
#define ll long long
#define bug cout<<"here"<<endl
#define fread freopen("ceshi.txt","r",stdin)
#define fwrite freopen("out.txt","w",stdout)

using namespace std;

int Read()
{
    char ch;
    int a = 0;
    while((ch = getchar()) == ' ' | ch == '\n');
    a += ch - '0';
    while((ch = getchar()) != ' ' && ch != '\n')
    {
        a *= 10;
        a += ch - '0';
    }
    return a;
}

void Print(int a)    //输出外挂
{
     if(a>9)
         Print(a/10);
     putchar(a%10+'0');
}

void Exgcd(ll a,ll b,ll &d,ll &x,ll &y)
{
    if(!b)
    {
        x=1; y=0; d=a;
    }
    else
    {
        Exgcd(b,a%b,d,y,x);
        y-=x*(a/b);
    }
}

int main()
{
//    fread;
    ll A,B,C,k;
    while(scanf("%lld%lld%lld%lld",&A,&B,&C,&k)!=EOF)
    {
        if(!(A+B+C+k)) break;
        ll a=C,b=(B-A);
        ll n=(ll)1<<k;
        ll d,x,y;
        Exgcd(a,n,d,x,y);
        if(b%d)
            puts("FOREVER");
        else
        {
            ll x0=x*(b/d);
            ll r=n/d;
            ll ans=(x0%r+r)%r;
            printf("%lld\n",ans);
        }
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: