您的位置:首页 > 其它

hdu 1175 连连看

2015-04-03 22:28 169 查看


Problem Description

“连连看”相信很多人都玩过。没玩过也没关系,下面我给大家介绍一下游戏规则:在一个棋盘中,放了很多的棋子。如果某两个相同的棋子,可以通过一条线连起来(这条线不能经过其它棋子),而且线的转折次数不超过两次,那么这两个棋子就可以在棋盘上消去。不好意思,由于我以前没有玩过连连看,咨询了同学的意见,连线不能从外面绕过去的,但事实上这是错的。现在已经酿成大祸,就只能将错就错了,连线不能从外围绕过。

玩家鼠标先后点击两块棋子,试图将他们消去,然后游戏的后台判断这两个方格能不能消去。现在你的任务就是写这个后台程序。


Input

输入数据有多组。每组数据的第一行有两个正整数n,m(0<n<=1000,0<m<1000),分别表示棋盘的行数与列数。在接下来的n行中,每行有m个非负整数描述棋盘的方格分布。0表示这个位置没有棋子,正整数表示棋子的类型。接下来的一行是一个正整数q(0<q<50),表示下面有q次询问。在接下来的q行里,每行有四个正整数x1,y1,x2,y2,表示询问第x1行y1列的棋子与第x2行y2列的棋子能不能消去。n=0,m=0时,输入结束。

注意:询问之间无先后关系,都是针对当前状态的!


Output

每一组输入数据对应一行输出。如果能消去则输出"YES",不能则输出"NO"。


Sample Input

3 4
1 2 3 4
0 0 0 0
4 3 2 1
4
1 1 3 4
1 1 2 4
1 1 3 3
2 1 2 4
3 4
0 1 4 3
0 2 4 1
0 0 0 0
2
1 1 2 4
1 3 2 3
0 0



Sample Output

YES
NO
NO
NO
NO
YES

该题是搜索加队列的运用的题目,主要是转折点的判断
代码如下
<pre name="code" class="cpp">#include<stdio.h>
#include<math.h>
#include<string.h>
#include<algorithm>
#include<queue>
using namespace std;
int map[1010][1010];   //游戏的图
int biaoji[1010][1010];   //标记走过的路
int dir[4][2]={0,1,1,0,0,-1,-1,0};  //判断方向
int n,m;
typedef struct  		//定义关于位置,转折 和方向的结构体
{
int x;
int y;
int fan;
int zhe;
}node;
node shi,mo;
void sou()  //搜索
{
queue<node> q;  //构造队列
node qian,cur;
shi.fan=-1;  //初始方向定为-1;
shi.zhe=0;   //初始转折为0
q.push(shi);
while(!q.empty())
{
qian=q.front();  //队首元素给qian
q.pop();
if(qian.x==mo.x&&qian.y==mo.y)  //如果此刻的坐标和末坐标一样
{
printf("YES\n");
return;
}
for(int i=0;i<4;i++) //四个方向寻找
{
cur.x=qian.x+dir[i][0];
cur.y=qian.y+dir[i][1];
cur.fan=i;
cur.zhe=qian.zhe;
if(cur.fan!=qian.fan&&qian.fan!=-1)   //如果此时的方向和之前不一样 转折加一
cur.zhe++;
if(cur.zhe>2||cur.x>n||cur.x<1||cur.y<1||cur.y>m)  //判断是否越界和转折多了
continue;
if(map[cur.x][cur.y]&&!(cur.x==mo.x&&cur.y==mo.y)) //如果之间有数字且未到最后
continue;
if(cur.zhe<biaoji[cur.x][cur.y])  //标记
{
biaoji[cur.x][cur.y]=0;
q.push(cur);
}
}
}
printf("NO\n");
}

int main()
{
int i,j;
while(~scanf("%d%d",&n,&m))
{
if(n==0&&m==0)  break;
int p;
for(i=1;i<=n;i++)
for(j=1;j<=m;j++)
{
scanf("%d",&map[i][j]);
}
scanf("%d",&p);
while(p--)
{
memset(biaoji,0,sizeof(biaoji));
scanf("%d%d%d%d",&shi.x,&shi.y,&mo.x,&mo.y);
if(shi.x==mo.x&&shi.y==mo.y)  //两个始末位置坐标一样
{
printf("NO\n");
continue;
}
if(map[shi.x][shi.y]==0||map[mo.x][mo.y]==0||map[shi.x][shi.y]!=map[mo.x][mo.y]) 
<span style="white-space:pre">							</span>//始末位置为空 或是不想等
{
printf("NO\n");
continue;
}

for(i=1;i<=n;i++)
for(j=1;j<=m;j++)
biaoji[i][j]=2010;
sou();
}
}
return 0;
}
</pre><pre name="code" class="html">
代码写得丑 但好理解 望见谅~




                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: