您的位置:首页 > 其它

hdu 1087 Super Jumping! Jumping! Jumping!(DP)

2015-04-03 09:30 141 查看

Super Jumping! Jumping! Jumping!

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 25057 Accepted Submission(s): 11073

[align=left]Problem Description[/align]
Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.



The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In
the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping
can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his
jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.

Your task is to output the maximum value according to the given chessmen list.

[align=left]Input[/align]
Input contains multiple test cases. Each test case is described in a line as follow:

N value_1 value_2 …value_N

It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.

A test case starting with 0 terminates the input and this test case is not to be processed.

[align=left]Output[/align]
For each case, print the maximum according to rules, and one line one case.

[align=left]Sample Input[/align]

3 1 3 2
4 1 2 3 4
4 3 3 2 1
0


[align=left]Sample Output[/align]

4
10
3


题目链接:vhttp://acm.hdu.edu.cn/showproblem.php?pid=1087

题目大意:找出长度为n的序列的最大递增子序列和(数字不要求连续),如例一:递增子序列有(1,)(1,3)(3)(1,2)(2),和 最大的是(1,3),和为4。

题目解析:DP,dp[i]表示包含a[i]的,前i个数字组成的序列的最大递增子序列和。初始化dp[i]=a[i],找到前面比a[i]小的数a[j],态转移返方程为:dp[i]=max(dp[i],dp[j]+a[i]).

#include <cstdio>
#include <cstring>
const int maxn=1005;
int a[maxn],dp[maxn];  //dp[i]表示包含第i个数字的前i个位置的最大子序列和
int main()
{
int n,i,j,max;
while(scanf("%d",&n)!=EOF&&n)
{
for(i=0;i<n;i++)
scanf("%d",&a[i]);
max=dp[0]=a[0];
for(i=1;i<n;i++)
{
dp[i]=a[i];   //初始化dp[i]
for(j=i-1;j>=0;j--)
{
if(a[j]<a[i]&&a[i]+dp[j]>dp[i])  //状态转移方程:dp[i]=max(a[i]+dp[j],dp[i])
{
dp[i]=dp[j]+a[i];
if(dp[i]>max)
max=dp[i];
}
}
}
printf("%d\n",max);
}
return 0;
}


代码如下:
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: