您的位置:首页 > 其它

MYOJ【省赛原题】表达式求值

2015-04-02 23:28 260 查看


表达式求值

时间限制:3000 ms  |  内存限制:65535 KB

描述

Dr.Kong设计的机器人卡多掌握了加减法运算以后,最近又学会了一些简单的函数求值,比如,它知道函数min(20,23)的值是20 ,add(10,98) 的值是108等等。经过训练,Dr.Kong设计的机器人卡多甚至会计算一种嵌套的更复杂的表达式。

假设表达式可以简单定义为:

1. 一个正的十进制数 x 是一个表达式。

2. 如果 x 和 y 是 表达式,则 函数min(x,y )也是表达式,其值为x,y 中的最小数。

3. 如果 x 和 y 是 表达式,则 函数max(x,y )也是表达式,其值为x,y 中的最大数。

4.如果 x 和 y 是 表达式,则 函数add(x,y )也是表达式,其值为x,y 之和。

例如, 表达式 max(add(1,2),7) 的值为 7。

请你编写程序,对于给定的一组表达式,帮助 Dr.Kong 算出正确答案,以便校对卡多计算的正误。

输入
第一行: N 表示要计算的表达式个数 (1≤ N ≤ 10) 

接下来有N行, 每行是一个字符串,表示待求值的表达式

(表达式中不会有多余的空格,每行不超过300个字符,表达式中出现的十进制数都不

超过1000。)
输出
输出有N行,每一行对应一个表达式的值。
样例输入
3
add(1,2)
max(1,999)
add(min(1,1000),add(100,99))


样例输出
3
999
200


#include<cstdio>
#include<algorithm>
#include<cmath>
#include<iostream>
#include<stack>
#include<queue>
#include<cstring>

using namespace std;
char s[320];
stack<char> str;
stack<int> num;
int jisuan()
{
int a,b,len;
len=strlen(s);
for(int i=0; i<len;)
{
if(isalpha(s[i]))
{
str.push(s[i+1]);
i+=4;
}
else if(isdigit(s[i]))
{
a=0;
while(isdigit(s[i]))
{
a=a*10+s[i]-'0';
i++;
}
num.push(a);
}
else if(s[i]==')')
{
a=num.top();
num.pop();
b=num.top();
num.pop();
if(str.top()=='d')/*加*/
{
num.push(a+b);
i++;
}
else if(str.top()=='a')/*大*/
{
num.push(a>b?a:b);
i++;

}
else if(str.top()=='i')/*小*/
{
num.push(a>b?b:a);
i++;
}
str.pop();

}
else i++;

}
return num.top();
}
int main()
{
int n;
cin>>n;
while(n--)
{
scanf("%s",s);
cout<<jisuan()<<endl;
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: