您的位置:首页 > 其它

POJ - 2886 Who Gets the Most Candies?(线段树)

2015-04-02 14:25 197 查看
Who Gets the Most Candies?

Time Limit: 5000MSMemory Limit: 131072KB64bit IO Format: %I64d & %I64u
Submit Status

Description

N children are sitting in a circle to play a game.

The children are numbered from 1 to N in clockwise order. Each of them has a card with a non-zero integer on it in his/her hand. The game starts from the K-th child, who tells all the others the integer
on his card and jumps out of the circle. The integer on his card tells the next child to jump out. Let A denote the integer. If A is positive, the next child will be the A-th
child to the left. If A is negative, the next child will be the (−A)-th child to the right.

The game lasts until all children have jumped out of the circle. During the game, the p-th child jumping out will get F(p) candies where F(p) is the number of positive integers
that perfectly divide p. Who gets the most candies?

Input

There are several test cases in the input. Each test case starts with two integers N (0 < N≤ 500,000) and K (1 ≤ K ≤ N)
on the first line. The next N lines contains the names of the children (consisting of at most 10 letters) and the integers (non-zero with magnitudes within 108) on their cards in increasing order of the children’s
numbers, a name and an integer separated by a single space in a line with no leading or trailing spaces.

Output

Output one line for each test case containing the name of the luckiest child and the number of candies he/she gets. If ties occur, always choose the child who jumps out of the circle first.

Sample Input

4 2
Tom 2
Jack 4
Mary -1
Sam 1


Sample Output

Sam 3


线段树,刚刚开始时把name和val都放在树里了,没必要而且要超时,比较难的地方在怎么处理出下次更新时的节点在第几个,要想一想,约数个数先处理出来。

#include<iostream>
#include<cstring>
#include<string>
#include<cstdio>
#include<algorithm>
using namespace std;
const int MAXN = 500010;
struct node
{
	int l, r, sum;
}tree[MAXN*3];

int father[MAXN];
char name[MAXN][15];
int val[MAXN];

void build(int l, int r, int i)
{
	tree[i].l = l; tree[i].r = r;
	if (l == r)
	{
		father[l] = i;
		tree[i].sum = 1;
		return;
	}
	int m = (l + r) >> 1, ls = i << 1, rs = ls + 1;
	build(l, m, ls);
	build(m + 1, r, rs);
	tree[i].sum = tree[ls].sum + tree[rs].sum;
}
int update(int len, int i)
{
	tree[i].sum--;
	if (tree[i].l == tree[i].r)
	{
		tree[i].sum = 0;
		return tree[i].l;
	}
	int m = (tree[i].l + tree[i].r) >> 1, ls = i << 1, rs = ls + 1;
	if (tree[ls].sum >= len) return update(len, ls);
	else return update(len - tree[ls].sum, rs);
}

int yue[MAXN];

int main()
{
	int n, k;
	for (int i = 1; i <= 500000;i++)
	for (int j = 1; j*i <= 500000; j++)
		yue[i*j]++;

	while (scanf("%d%d", &n, &k) != EOF)
	{
		build(1, n, 1);
		for (int i = 1; i <= n; i++)
		{
			scanf("%s%d",name[i], &val[i]);
		}

		/*for (int i = 1; i <= n; i++)
		{
		cout << i << " " << father[i] << " " << name[i] << " " << val[i] << endl;;
		}*/

		if (n == 1)
		{
			cout << name[1] << " " <<1<< endl;
			continue;
		}

		int op = k;
		int cnt = n;

		char ans_name[15];
		int ans=0;

		for (int i = 1; i <= n; i++)
		{
			int v=update(k, 1);
			cnt--;

			/*for (int i = 0; i < 15; i++)
				cout << i << " " << tree[i].sum << endl;
            */

			if (yue[i] > ans)
			{
				ans = yue[i];
				strcpy(ans_name, name[v]);
			}

			if (i == n) break;

			v = val[v];
			if (v>0)
			{
				k = ((k-1+v-1)%cnt+cnt)%cnt+1;	
			}
			else
			{
				k = ((k - 1 + v) % cnt + cnt) % cnt + 1;
			}
		}
		cout << ans_name << " " << ans << endl;

	}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: