您的位置:首页 > 编程语言 > Go语言

HDU 2669 Romantic(扩展欧几里得)

2015-03-31 22:13 190 查看


Romantic

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3235    Accepted Submission(s): 1280


[align=left]Problem Description[/align]
The Sky is Sprite.

The Birds is Fly in the Sky.

The Wind is Wonderful.

Blew Throw the Trees

Trees are Shaking, Leaves are Falling.

Lovers Walk passing, and so are You.

................................Write in English class by yifenfei



Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem!

Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead.

 

[align=left]Input[/align]
The input contains multiple test cases.

Each case two nonnegative integer a,b (0<a, b<=2^31)

 

[align=left]Output[/align]
output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put "sorry" instead.

 

[align=left]Sample Input[/align]

77 51
10 44
34 79

 

[align=left]Sample Output[/align]

2 -3
sorry
7 -3

 

[align=left]Author[/align]
yifenfei
 

[align=left]Source[/align]
HDU女生专场公开赛——谁说女子不如男

 

这题有毒,,定义要__int64 输出输入要cout,cin。。
扩展欧几里得的裸题。

扩展欧几里德: 给一个线性方程X*a+Y*b=m,给出a,b,m让求解X和Y。

首先,只有m%gcd(a,b)==0 时 该线性方程才有解。

假使a=k1 *gcd(a,b),b=k2 * gcd(a,b);

那么方程左边就等于(X*k1+Y*k2)*gcd(a,b),所以仅当m能被gcd(a,b)整除时方程才有解。

为了求上述方程的解,我们不妨先来求方程a*X+b*Y=gcd(a,b)的解,设d=m/gcd(a,b);

所以a*(d*X)+b*(d*y)=d*gcd(a,b)=m,求出这个方程的解原方程的解也就求出了。

根据欧几里德有gcd(a,b)=gcd(b,a%b)

所以a*X+b*Y=gcd(a,b)=gcd(b,a%b)=b*X1+(a%b)*Y1;

令k=a/b , r=a%b

a=b*k+r;

得出X=Y1 ,  Y=X1-Y1*(a/b);

#include "string"
#include "iostream"
#include "cstdio"
#include "cmath"
#include "set"
#include "queue"
#include "vector"
#include "cctype"
#include "sstream"
#include "cstdlib"
#include "cstring"
#include "stack"
#include "ctime"
#include "algorithm"
#define pa pair<int,int>
#define Pi M_PI
#define INF 0x3f3f3f3f
#define INFL 0x3f3f3f3f3f3f3f3fLL
using namespace std;
typedef long long ll;
__int64 EXgcd(__int64 a,__int64 b,__int64& x,__int64& y)
{
if(b==0)
{
x=1;
y=0;
return a;
}
__int64 r=EXgcd(b,a%b,x,y);
__int64 t=x;
x=y;
y=t-a/b*y;
return r;
}
int main()
{
__int64 a,b,x,y,Gcd;
while(cin>>a>>b)
{
Gcd=EXgcd(a,b,x,y);
if(Gcd==1)//为一才有解
{
while(x<0)
{
x+=b;
y-=a;
}
cout<<x<<" "<<y;
}
else
cout<<"sorry";
cout<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息