您的位置:首页 > 其它

HDU 4965 Fast Matrix Calculation(矩阵快速幂)

2015-03-31 11:16 411 查看
Description

One day, Alice and Bob felt bored again, Bob knows Alice is a girl who loves math and is just learning something about matrix, so he decided to make a crazy problem for her.

Bob has a six-faced dice which has numbers 0, 1, 2, 3, 4 and 5 on each face. At first, he will choose a number N (4 <= N <= 1000), and for N times, he keeps throwing his dice for K times (2 <=K <= 6) and writes down its number on the top face to make an N*K
matrix A, in which each element is not less than 0 and not greater than 5. Then he does similar thing again with a bit difference: he keeps throwing his dice for N times and each time repeat it for K times to write down a K*N matrix B, in which each element
is not less than 0 and not greater than 5. With the two matrix A and B formed, Alice’s task is to perform the following 4-step calculation.

Step 1: Calculate a new N*N matrix C = A*B.

Step 2: Calculate M = C^(N*N).

Step 3: For each element x in M, calculate x % 6. All the remainders form a new matrix M’.

Step 4: Calculate the sum of all the elements in M’.

Bob just made this problem for kidding but he sees Alice taking it serious, so he also wonders what the answer is. And then Bob turn to you for help because he is not good at math.


Input

The input contains several test cases. Each test case starts with two integer N and K, indicating the numbers N and K described above. Then N lines follow, and each line has K integers between 0 and 5, representing matrix A. Then
K lines follow, and each line has N integers between 0 and 5, representing matrix B.

The end of input is indicated by N = K = 0.


Output

For each case, output the sum of all the elements in M’ in a line.


Sample Input

4 2
5 5
4 4
5 4
0 0
4 2 5 5
1 3 1 5
6 3
1 2 3
0 3 0
2 3 4
4 3 2
2 5 5
0 5 0
3 4 5 1 1 0
5 3 2 3 3 2
3 1 5 4 5 2
0 0




Sample Output

14
56



当初写到这个题,一看n这么大,二维mat快速幂肯定不行。想了好久


所以将B*A之后快速幂就变成最大6*6的了。

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
#include<string>
#include<iostream>
#include<queue>
#include<cmath>
#include<map>
#include<stack>
#include<bitset>
using namespace std;
#define REPF( i , a , b ) for ( int i = a ; i <= b ; ++ i )
#define REP( i , n ) for ( int i = 0 ; i < n ; ++ i )
#define CLEAR( a , x ) memset ( a , x , sizeof a )
typedef long long LL;
typedef pair<int,int>pil;
const int INF = 0x3f3f3f3f;
int M1[1100][10],M2[10][1100];
int M3[1100][1100],M4[1100][1100];
struct Matrix{
    int mat[10][10];
    void Clear()
    {
       CLEAR(mat,0);
    }
};
Matrix M;
int n,kk;
Matrix mult(Matrix m1,Matrix m2)
{
    Matrix ans;
    for(int i=0;i<kk;i++)
        for(int j=0;j<kk;j++)
        {
            ans.mat[i][j]=0;
            for(int k=0;k<kk;k++)
               ans.mat[i][j]=(ans.mat[i][j]+m1.mat[i][k]*m2.mat[k][j])%6;
        }
    return ans;
}
Matrix Pow(Matrix m1,int b)
{
    Matrix ans;ans.Clear();
    for(int i=0;i<kk;i++)
        ans.mat[i][i]=1;
    while(b)
    {
        if(b&1)
            ans=mult(ans,m1);
        b>>=1;
        m1=mult(m1,m1);
    }
    return ans;
}
int main()
{
    while(~scanf("%d%d",&n,&kk)&&(n+kk))
    {
        for(int i=0;i<n;i++)
            for(int j=0;j<kk;j++)  scanf("%d",&M1[i][j]);
        for(int i=0;i<kk;i++)
            for(int j=0;j<n;j++)  scanf("%d",&M2[i][j]);
        for(int i=0;i<kk;i++)
            for(int j=0;j<kk;j++)
            {
                M.mat[i][j]=0;
                for(int k=0;k<n;k++)
                    M.mat[i][j]=(M.mat[i][j]+M2[i][k]*M1[k][j])%6;//B*A
            }
        M=Pow(M,n*n-1);
        for(int i=0;i<n;i++)
            for(int j=0;j<kk;j++)
            {
                M3[i][j]=0;
                for(int k=0;k<kk;k++)
                    M3[i][j]=(M3[i][j]+M1[i][k]*M.mat[k][j])%6;//M3
            }
        for(int i=0;i<n;i++)
            for(int j=0;j<n;j++)
            {
                M4[i][j]=0;
                for(int k=0;k<kk;k++)
                    M4[i][j]=(M4[i][j]+M3[i][k]*M2[k][j])%6;
            }
        LL ans=0;
        for(int i=0;i<n;i++)
            for(int j=0;j<n;j++)
              ans+=M4[i][j];
        printf("%lld\n",ans);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: