您的位置:首页 > 其它

ZOJ1003

2015-03-30 22:52 274 查看
On every June 1st, the Children's Day, there will be a game named "crashing balloon" on TV. The rule is very simple. On the ground there are 100 labeled balloons, with the numbers 1 to 100. After the referee shouts "Let's go!"the two players, who each
starts with a score of "1", race to crashthe balloons by their feet and, at the same time,multiply their scores by the numbers written on the balloons they crash. After a minute, the little audiences are allowed to take the remaining balloons away, and each
contestant reports his\her score, the product of the numberson the balloons he\she's crashed. The unofficial winner is the player whoannounced the highest score.

Inevitably, though, disputes arise, and so the official winner is notdetermined until the disputes are resolved. The player who claimsthe lower score is entitled to challenge his\her opponent's score. Theplayer with the lower score is presumed to have
told the truth, becauseif he\she were to lie about his\her score, he\she would surely come up with a biggerbetter lie. The challenge is upheld if the player with the higherscore has a score that cannot be achieved with balloons not crashed by thechallenging
player. So, if the challenge is successful, the playerclaiming the lower score wins.

So, for example, if one player claims 343 points and the other claims49, then clearly the first player is lying; the only way to score 343 isby crashing balloons labeled 7 and 49, and the only way to score 49 is by crashinga balloon labeled 49. Since each
of two scores requires crashing theballoon labeled 49, the one claiming 343 points is presumed to be lying.

On the other hand, if one player claims 162 points and the other claims81, it is possible for both to be telling the truth (e.g. one crashes balloons2, 3 and 27, while the other crashes balloon 81), so the challenge would notbe upheld.

By the way, if the challenger made a mistake on calculating his/her score, then the challenge would not be upheld. For example, if one player claims 10001 points and the other claims 10003, then clearly none of them are tellingthe truth. In this case, the
challenge would not be upheld.

Unfortunately, anyone who is willing to referee a game of crashing balloon islikely to get over-excited in the hot atmosphere that he\she could not reasonably be expected to perform the intricate calculationsthat refereeing requires. Hence the need for
you, sober programmer,to provide a software solution.

Input

Pairs of unequal, positive numbers, with each pair on a single line, thatare claimed scores from a game of crashing balloon.

Output

Numbers, one to a line, that are the winning scores, assuming that theplayer with the lower score always challenges the outcome.

Sample Input

343 49
3599 610
62 36

Sample Output

49
610
6

import java.util.Scanner;
import java.util.Stack;

public class ZOJ1003 {
	private static int num[];
	private static String strIn;
	private static String strOut;
	public static void main(String[] args) {
		Scanner in =new Scanner(System.in);
		strIn = in.nextLine();
		strOut = in.nextLine();
		num= new int[2*strIn.length()];
		build(0);
		
	} 
	public static void build(int cur){
		int len = num.length;
		if(cur==len){
			String string = createOut(num,strIn);
			if(string.equals(strOut)){
				print(num);
				System.out.println();
			}
			return ;
		} 
			if(hasLessHalfOne(num,cur)){
				num[cur] = 1;
				build(cur+1);
			}
			if(hasLessHalfZero(num,cur) && hasLessOne(num,cur)){
				num[cur] = -1;
				build(cur+1);
			}
		
		
	}
	private static boolean hasLessOne(int[] num, int cur) {
		int countOne = 0;// number of One
		for(int i=0;i<cur;i++){
			if(num[i]==1){
				countOne++;
			}
		}
		
		return cur-countOne < countOne ? true : false;
	}
	public static boolean hasLessHalfZero(int[] num, int cur) {
		int count=0,len = num.length;
		for(int i=0;i<cur;i++){
			if(num[i]==-1){
				count++;
			}
		}
		if(len%2!=0){
			len++;
		}
		return count<len/2 ? true : false ;
	}
	public static boolean hasLessHalfOne(int[] num, int cur) {
		int count=0,len = num.length;
		for(int i=0;i<cur;i++){
			if(num[i]==1){
				count++;
			}
		}
		if(len%2!=0){
			len++;
		}
		return count<len/2 ? true : false ;
	}
	private static void print(int[] num) {
		for(int i=0;i<num.length;i++){
			if(num[i]==1){
				System.out.print("i ");
			}else{
				System.out.print("o ");
			}
		}
		
	}
	public static String createOut(int[] num, String strIn) {
		Stack<Character> stack = new Stack<>();
		StringBuilder sb = new StringBuilder();
		int index = 0;
		for(int i=0;i<num.length;i++){
			if(num[i]==1){
				stack.push(strIn.charAt(index++));
			}else{
				sb.append(stack.pop());
			}
			
		}
		return sb.toString();
	}

}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: