您的位置:首页 > 其它

[PAT]1002. A+B for Polynomials(25)

2015-03-30 17:00 585 查看

思路

直接用数组下标作为指数,数组内容作为系数即可

千万注意范围,之前因为没有注意范围所以没有ac,指数的范围是1~1000,要开大一点

代码

/*
1002. A+B for Polynomials (25)

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 2 1.5 1 2.9 0 3.2

*/

#include <stdio.h>
int main(int argc, const char * argv[])
{
int m,n;
int i;
int k=0;
int index;
float num;
float a[1001]={0},b[1001]={0},c[1001]={0};

scanf("%d",&m);
for (i=0; i<m; i++)
{
scanf("%d",&index);
scanf("%f",&num);
a[index]=num;

}
scanf("%d",&n);
for (i=0; i<n; i++)
{
scanf("%d",&index);
scanf("%f",&num);
b[index]=num;
}

for (i=0; i<1001; i++)
{
c[i]=a[i]+b[i];
if (c[i]!=0)
{
k++;
}
}

printf("%d",k);
for (i=1000; i>=0; i--)
{
if (c[i]!=0)
{
printf(" %d %.1f",i,c[i]);
}
}
printf("\n");
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  pat