您的位置:首页 > 其它

hdu 2586(LCA+并查集)

2015-03-29 21:23 375 查看


How far away ?

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 6734 Accepted Submission(s): 2498



Problem Description

There are n houses in the village and some bidirectional roads connecting them. Every day peole always like to ask like this "How far is it if I want to go from house A to house B"? Usually it hard to answer. But luckily int this village the answer is always
unique, since the roads are built in the way that there is a unique simple path("simple" means you can't visit a place twice) between every two houses. Yout task is to answer all these curious people.

Input

First line is a single integer T(T<=10), indicating the number of test cases.

For each test case,in the first line there are two numbers n(2<=n<=40000) and m (1<=m<=200),the number of houses and the number of queries. The following n-1 lines each consisting three numbers i,j,k, separated bu a single space, meaning that there is a road
connecting house i and house j,with length k(0<k<=40000).The houses are labeled from 1 to n.

Next m lines each has distinct integers i and j, you areato answer the distance between house i and house j.

Output

For each test case,output m lines. Each line represents the answer of the query. Output a bland line after each test case.

Sample Input

2
3 2
1 2 10
3 1 15
1 2
2 3

2 2
1 2 100
1 2
2 1


Sample Output

10
25
100
100


Source

ECJTU 2009 Spring Contest

Recommend

lcy

就是一个最近公共祖先问题,tarjan算法,说白了只是一个dfs。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
#define maxn 40010
typedef struct node{
int v,d;
int next;
}Node;

int index;
int head[maxn];
Node edge[2*maxn];

int index1;
int head1[maxn];
Node edge1[2*maxn];

int res[210][3];
int f[maxn];
int vis[maxn];
int dis[maxn];
int n,m;

void add(int u,int v,int d){
index++;
edge[index].v=v;
edge[index].d=d;
edge[index].next=head[u];
head[u]=index;
}
void add1(int u,int v,int d){
index1++;
edge1[index1].v=v;
edge1[index1].d=d;
edge1[index1].next=head1[u];
head1[u]=index1;
}
int find(int x){
if(x!=f[x]){
f[x]=find(f[x]);
return f[x];
}
return x;
}
void tarjan(int u){
vis[u]=1;
f[u]=u;

for(int p=head1[u];p;p=edge1[p].next){
if(vis[edge1[p].v]){
res[edge1[p].d][2]=find(edge1[p].v);
}
}

for(int p=head[u];p;p=edge[p].next){
if(vis[edge[p].v]==0){
dis[edge[p].v]=dis[u]+edge[p].d;
//if(dis[edge[p].v]){
//  printf("%d\n",dis[edge[p].v]);
//}
tarjan(edge[p].v);
f[edge[p].v]=u;
}
}
}
int main(){
int T;
scanf("%d",&T);
while(T--){
scanf("%d%d",&n,&m);

memset(head,0,sizeof(head));
index=0;
for(int i=1;i<n;i++){
int u,v,d;
scanf("%d%d%d",&u,&v,&d);
add(u,v,d);
add(v,u,d);
}

memset(head1,0,sizeof(head1));
index1=0;
for(int i=0;i<m;i++){
int u,v;
scanf("%d%d",&u,&v);
res[i][0]=u;
res[i][1]=v;
add1(u,v,i);
add1(v,u,i);
}
memset(vis,0,sizeof(vis));
dis[1]=0;
tarjan(1);
//for(int i=1;i<=n;i++){
//  printf("%d ",dis[i]);
//}
//printf("\n");
for(int i=0;i<m;i++){
printf("%d\n",dis[res[i][0]]+dis[res[i][1]]-2*dis[res[i][2]]);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: