您的位置:首页 > 编程语言 > Go语言

HDU - 1397 Goldbach's Conjecture

2015-03-29 02:46 316 查看
Goldbach's Conjecture

Time Limit: 1000MSMemory Limit: 32768KB64bit IO Format: %I64d & %I64u
Submit Status

Description

Goldbach's Conjecture: For any even number n greater than or equal to 4, there exists at least one pair of prime numbers p1 and p2 such that n = p1 + p2.

This conjecture has not been proved nor refused yet. No one is sure whether this conjecture actually holds. However, one can find such a pair of prime numbers, if any, for a given even number. The problem here is to write a program that reports the number of
all the pairs of prime numbers satisfying the condition in the conjecture for a given even number.

A sequence of even numbers is given as input. Corresponding to each number, the program should output the number of pairs mentioned above. Notice that we are interested in the number of essentially different pairs and therefore you should not count (p1, p2)
and (p2, p1) separately as two different pairs.



Input

An integer is given in each input line. You may assume that each integer is even, and is greater than or equal to 4 and less than 2^15. The end of the input is indicated by a number 0.



Output

Each output line should contain an integer number. No other characters should appear in the output.



Sample Input

6
10
12
0




Sample Output

1
2
1




#include<iostream>
#include<vector> //首先筛出素数,用vis标记每个数是不是素数,然后对于询问就for一遍看下每种拆分是不是两个都是素数。
using namespace std;
const int MAXN = 1000000;  //注意要开的够大
int vis[MAXN];

void Prime() //素数筛
{
	vis[0] = 1; vis[1] = 1;
	for (long long int i = 2; i*i <= MAXN; i++)
	{
		if (!vis[i])
		{
			for (long long int j = i+i; j <= MAXN; j = j + i)
				vis[j] = 1;
		}
	}
	return;
}

int main()
{
	Prime();
	long long int n;
	while (cin >> n&&n)
	{
		long long int sum = 0;
		for (long long int i = 2; i <=n/2; i++)
		{
			if (!vis[i] && !vis[n - i]) sum++;
		}
		cout << sum << endl;
	}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: