您的位置:首页 > 产品设计 > UI/UE

ZOJ - 1733 Common Subsequence

2015-03-28 16:27 211 查看
Common Subsequence

Time Limit: 2000MSMemory Limit: 65536KB64bit IO Format: %lld & %llu
Submit Status

Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2,
..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length
common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the
standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc abfcab

programming contest

abcd mnp

Sample Output

4

2

0

最长公共子序列
#include<iostream>
#include<cstring>
#include<string>
#include<algorithm>
using namespace std;
int dp[1010][1010];
int main()
{
	string a, b;
	while (cin >> a >> b)
	{
		memset(dp, 0, sizeof(dp));
		int lena = a.length();
		int lenb = b.length();
		for (int i = 0; i < lena; i++)
		for (int j = 0; j < lenb; j++)
		{
			if (a[i] == b[j]) dp[i + 1][j + 1] = dp[i][j] + 1;
			else dp[i + 1][j + 1] = max(dp[i][j + 1], dp[i + 1][j]);
		}
		cout << dp[lena][lenb] << endl;

	}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: